Report
5 years, 5 months ago.

Can't get full debugging on mbed-enabled FRDM KL25Z.

Hi,

I just went through the setup procedure for my FRDM-KL25Z today (with windows vista7 Installed mbed_if_v2.0_frdm_kl25z.s19 into the KL25z. Installed mbedWinSerial_16466.exe drivers to the PC. (See "full debugging interface on mbed-enabled platforms. Samuel Mokrani, 02 Apr 2013")

I encountered a problem and have been asked by 0xc0170 to move my question to here.

Exported a simple blinkyHelloworld program. The program exported ok and appears to have built ok.

It went very smooth up to the point where I tried to download the result of the compilation onto the KL25Z. I got the following popup: (Using uVision V5.0.5.15)

/media/uploads/hallher379/failure_to_download.jpg

This is what my device(s) look like after doing the setup:

/media/uploads/hallher379/mbed_serial_after_cmsis-dp_install.jpg

I think there is a problem at this point because the MBED CMSIS-DAP device is not there. I don't know why.

I clicked on the popup, which took me to another, that said that the flash erase failed:

/media/uploads/hallher379/erase_failed.jpg

So, it looks like uVision is not communicating with the KL25Z. One person suggested that I didn't have uVision configured correctly. If this is the case can you post a screen shot of the correct configuration.

In my case, I go to Project -> Manage -> Migrate to version 5 format, then close the project and reopen. Now it can recognize the device and debug normally with Keil

posted by Trung Le Dinh 14 Apr 2015
Comment on this question

2 Answers

5 years, 5 months ago.

Hello Herschel Hall,

I have replicated your issue. You did what I have seen, everything correctly, but KEIL is not set up completely. Here's my proposed solution:

1. You either install uVision 4.xx, which worked for me so far (those flash algorithms are included). 2. Search for mdkcm500. You installed only "pure" version of KEIL which does not contain flash algorithms for kinetis. Go to the installed directory KEIL\ARM\Flash. I believe you have only 2 devices there. I have installed mdkcm500 (which should be also available online somewhere).

If you need further information about the second option (why those flash files are not included ), contact their support.

Regards,
0xc0170

Hi 0xc0170,

posted by Herschel Hall 13 Nov 2013

Hi 0xc0170,

posted by Herschel Hall 13 Nov 2013

Let's try this again (stay away from the enter key). Just wanted to let you know that I installed uVision 4.73. Then exported a simple project from mbed/compiler, and was able (after much slogging around) to arrive at a uVision configuration that let me build it, download it to my frdm kl25z, and set a breakpoint that worked!!! Now lets hope I can do it again. Thanks so much for your help :>)

posted by Herschel Hall 13 Nov 2013

I am trying to export KL05 to uVision5 also and have the same problem. I cannot find the suggested mdkcm500 file.

Thanks, Tom

posted by Tom Russell 09 Mar 2015
5 years, 5 months ago.

You probably need to install the serial port driver.

Cheers, Sam

Hi Sam, I have installed (several times) what I think is the correct driver: mbedWinSerrial_16466.exe. The confusing thing is that I can never get the MBED CMSIS-DAP device to show up in the device manager. However, I find now that it may be ok as is. see my comment below please.

posted by Herschel Hall 13 Nov 2013

To post an answer, please log in.