10 years, 8 months ago.  This question has been closed. Reason: Problem solved

mbed dead?

Hi all, I think I may have done something to horribly mess up my mbed!

I was having some odd problems with a program and took a look at the mbed drive on my Windows system. Well, it showed 2 copies of every file on the drive. One had the proper size and the other being zero bytes. I then deleted all of the .bin files but the zero byte size files showed back up. Now I can't copy to the mbed drive at all.

One thing that may lead to a possible solution is that I just upgraded to the latest firmware (141212) and there are some known problems using LocalFileSystem with that version where it will not release the file system after a program closes all references to open files. I had been using a program that was accessing the file system, but then switched over to a different program to test something else.

Any and all suggestions are appreciated!

2 Answers

10 years, 8 months ago.

What I would try is a variation on Gopal's answer.

Well first just try formatting the mbed drive. If that doesn't work, press the reset switch before plugging the mbed in, keep it pressed (this way no user program can start and do anything with the file system), and then delete everything/format your drive.

Accepted Answer

Reformatting worked like a charm.

I had thought about trying that but didn't want to try that before someone confirmed it was OK and that I wouldn't destroy anything.

posted by Tim Borland 15 Oct 2013
10 years, 8 months ago.

I don't konw if this is valid documented or not but I did end up in similar situation a month back.

I had copied a bin file which was built using IAR. The linker script (scatter file) had linked the program for putting it into flash area and probably that had conflicted with something from the mbed firmware. Thereafter the mbed was not recognized by Windows at all. It just kept on saying "USB device not recognized".

Well, I tried this randomly - Take off USB power from mbed. Press the reset switch and apply power with the button still pressed. This probably restored the old firmware. My mbed then started working properly.

Hope it helps !