Report
5 years, 8 months ago.

Is importing a library not functioning?

When I try to import libraries (e.g. MODSERIAL, SDFileSystem, etc), I get the error "Connection Error: server responded with failure code 500". The server is https://mbed.org .

I have tried using Chromium and Firefox on two different computers, running different versions of Ubuntu.

I have tried importing libraries to different programs.

I am, however, able to import programs normally, and am able to download the libraries from their web sites and upload them from my disk.

I am also able to update libraries that have already been imported.

Is anyone else seeing this behavior?

Same issue here. Normal place is the bugs and suggestions forum to mention this. Staff generally checks questions also, but I think bugs they check more often.

posted by Erik Olieman 08 Oct 2013
Comment on this question

2 Answers

-deleted-
5 years, 8 months ago.

Hi S K UCI, Kevin,

The issue is now fixed and the library importing is restored. It was affecting only the beta mode Compiler.

When you're experiencing a problem with the mbed website/Compiler, check if have beta mode turned on. Even though we test betas, sometimes a bug can be specifically tied to a workspace, effectively escaping our "sight". The beta mode is indicated with a red "[ Beta ]" button above the "Logout" button on the website.

Thanks for reporting this and for using beta to test the upcoming release!

Cheers,
Mihail

Hi Mihail, As a new user I am not aware of becoming a "beta" user. Is this the default? Sadly I do not respond to Microsoft error messages especially generic ones. I waited and hoped for three days that someone else would raise this as a fault! I now understand why so few users had this problem. I have turned "beta" user off. Regards Kevin.

posted by Kevin Gordon 08 Oct 2013

Thanks! I also had no idea I was a beta user.

posted by S K UCI 08 Oct 2013
5 years, 8 months ago.

Hi S K UCI, I have had exactly the same problem for three days (still on going). It has happened in the past. Forum replies do not explain how to resolve the problem. I am new so I do not know of any official channel to get the web master to explain the cause. The error states that the server failed and doing retries keeps giving the same error message. I have tried direct library import and using the wizard.

Please someone tell us the solution! or WAKE UP THE WEB MASTER!


To post an answer, please log in.