10 years ago.


Hi all,

I recently bought a FRDM KL25Z board made by Freescale. The USB storage device programmer works on almost every PC but my own! I've installed Windows 8.1 on both machines. When I start Ubuntu on one of the systems (the desktop) the programmer storage device does work so the problem seems to be related to Windows.

All ports on my laptop are USB 3.0, on my desktop some are 2.0, some 3.0. When I plug in the device, nothing happens but a fast flickering green led on the board, if I wait somewhat longer (30 sec) the Windows Explorer window vanishes and reopens but now there is a new file present that is called 'FAIL.TXT' which has the content: 'TIMEOUT'.

Does anyone knows how to solve this?

Device config log:

Device USBSTOR\Disk&Ven_MBED&Prod_microcontrolleur&Rev1.0\02000200240291955EA25EE7&0 was configured.

Driver Name: disk.inf Class Guid: {4D36E967-E325-11CE-BFC1-08002BE10318} Driver Date: 06/21/2006 Driver Version: 6.3.9600.16384 Driver Provider: Microsoft Driver Section: disk_install.NT Driver Rank: 0xFF0006 Matching Device Id: GenDisk Outranked Drivers: disk.inf:GenDisk:00FF2002 Device Updated: false

FRDM KL25Z board is fully supported in windows operating system. but sometimes Windows 8 is occur some problem such types of board. For instant support related to the Change Roadrunner Password please visite http://www.roadrunnersupport247.com/change-roadrunner-password/ for the best solution.

posted by Mark Ford 04 Jun 2019

4 Answers

9 years, 12 months ago.

Hi Tom - Sorry to hear your having troubles. Can you tell me more about how your computers are setup? Is this a dual boot system or are you using a VM?

EDIT We are aware that only the mbed LPC11U24 and mbed LPC1768 currently work with Windows 8 (and 8.1). We are looking into this and will have an update soon.

Hi Sam,

My laptop was just re installed with Windows 8.1 Pro (64bit), it's a standard Sony Vaio Pro including USB 3.0. My desktop has also USB 3.0 but connecting my board to a USB 2.0 port didn't make any difference. I've tried my two computers, different boards, different cables and different ports but nothing made a difference.

Because I really needed to get things working as it's required for a compulsory course I eventually created an Ubuntu Live USB: things worked instant! My laptop doesn't support dual-boot that easy so I installed a virtual machine with Ubuntu on it (VirtualBox) disabled the MBED device in Windows Device Manager and redirected it through VirtualBox to the Ubuntu Virtual Machine: it worked! So it really looks like a software issue to me.

posted by Tom Tom 05 Oct 2013

hi tom, i'm new in these topic, can you please explain me a little bit more about it?? I already have installed ubuntu virtual machine, but i don't manage to change portsw and stuff, can you please help me?

i searched about it and the problem seems to be with windows when it runs the bootloader

posted by roberto vite 21 Oct 2013

Hi Roberto,

I've installed VirtualBox (as Microsoft's solutions have no USB-support) and disabled the MBED device in the Windows Devicemanager (compmgmt.msc). When the Ubuntu machine is started I attach the USB cable to my board and rightclick the 'Connector' icon in the bottom-left corner of VirtualBox. Here I can select the Mbed device to be recognized by the virtual machine. This works for me.

So what you are saying is that Windows tries to execute something from the device?

posted by Tom Tom 23 Oct 2013
5 years, 9 months ago.

Solution : i tried this solution ans its work: launch the editor, use Windows+R, then type


and after go to Computer Configuration \ Administrative Templates \ Windows Components \ Search \ Do not allow locations on removable drives to be added to libraries

and activate this option.

For more information watch this video : https://www.youtube.com/watch?v=PbWO_Jk9yqc

9 years, 11 months ago.

I'm having the same problem. I'm 8.1 as well.

9 years, 11 months ago.

HI guys

I have found this in great blog of Erich