9 years, 5 months ago.

Have I destroyed my application board?

I have been trying to get mbed application board and mbed working together, with no success after the first few minutes.

I tried a 7.5V supply into the App board, in case the USB was overloaded. Over the past three days I have tried all sorts of things, but I realised the I have plugged the mbed into the app board the wrong way round, and in my panic I plugged it in again one pin along, with pins 1 and 40 overhanging. Now I have only the status LED alight, with the mbed on its own, but that goes out when I plug into the app board.

Please, have I done some expensive damage? I can solder many SMD, so can I locate and replace damaged IC?

Must I cut my losses and give up mbed for ever?

2 Answers

9 years, 5 months ago.

Well you don't need to give up mbed forever, you may need to buy a new application board (tbh I agree it could have been included how you should mount the mbed). Does the mbed still works on its own? (You say status light is on, but if you for example just upload a blinking led program, does that work?).

A quick look at the wiring shows really many things that can be broken, mainly by the case where it is overhanging.

What exactly is destroyed is hard to say, good chance buying a new one is the easiest solution.

8 years, 10 months ago.

Something similar happened to my LPC11U24 board. After weeks of successful testing, suddenly I could not copy new bin files to the usb drive. My linux host reports, "no medium found", resp. "detected capacity change from 2097152 to 0". The last program stored on the board still works, and even sends messages through the serial usb console. Is there any hope to get the thing working?

I could solve my problem. Obviously I had ignored this documentation: http://mbed.org/handbook/LocalFileSystem I had a file opened in the local file system and kept it open. In this state the file system is not visible from the PC via USB. I keep that file closed now and reopen it only when writing to it. This solved my issue.

posted by Eggert Ehmke 26 Jan 2014