11 years, 2 months ago.

KL25Z On Chip USB

After a lot of struggle, (install/uninstall drivers, etc.), I was able to get the com virtual port working with the SDA USB port. I can't figure out how to use the other (on-chip) USB port. I only have one COM port showing in windows, and have tried plugging, unplugging, installing, uninstalling, with or without the reset button. Can't get windows to recognize it.

If I were to get it to recognize it, not sure which libraries to use to program it.

I have similar problem too! I have drivers installed, the mbed device shows in device manager, but I cant get it to show under COM ports. I tried it on friends mac and it was working properly, so the code on the board itself is ok, I just cant receive any data on windows as I cant find any port to listen to >.< Arduino Uno immeadeately showed under COM ports, but I cant get this board to show >.<

Edit: I finally got it to work with a serial driver I found (looks like it has to be installed separately), the first post I found said I need to point it to some serial.inf file, which didn't work.

posted by D B 05 Dec 2013

2 Answers

11 years, 2 months ago.

You first need to program it before it will show up as anything, unprogrammed it is essentially unconnected for your computer, it also wouldn't know what kind of USB device it should be.

For libraries to use, see: http://mbed.org/handbook/USBDevice

11 years, 2 months ago.

I doubt that it works at all with the Freedom board! I know, mbed people say it works with their units, but they must be definitefly different from the board I purchased. I tried different cables etc. I simply compiled the USBSerial example - no com port showed up. The only device/port I can see in Windows 8 device manager is the SDA USB. If you need a fast USB device, check out the Teensy 3.0 (ARM Cortex M4). It's sad, bus CDC USB is definitifely not a feature of mbed.

It is too bad you have issues with your board, but that is no reason to act like it can't work with the KL25 board.

posted by Erik - 12 May 2013