1 year, 4 months ago.

Unable to Write to FRDM-K64F

Hello,

I know my question sounds like many others on these forums, but none of the other answers have worked. Any advice would be greatly appreciated. I will attempt to document this process as clearly as possible.

I recently obtained a FRDM-K64F board for a project I will be working on. I took it out of the box and plugged it in to my laptop running Windows 10, hoping to see the demo as the insert explained in the packaging. The board appeared as a drive on my computer, but I didn't see anything happening on the board itself. I went to the link included in the paper guide that came with the board, I looked for a Quick Start guide. I then followed these instructions. When it didn't work again, I went to the community forums and there found out that there are some known issues with Windows 10. I followed the advice of several people, but to no avail. I first downloaded the drivers and ran the installer. When this didn't appear to work, I tried restarting my computer, uninstalling and reinstalling the drivers, and power cycling the board several times. I currently have drivers, but maybe these aren't working as expected. The board would reset when I would try to copy any file to it, and when it would reload, the same mbed.htm file would reappear. Various combinations of power cycling, pressing reset, etc. didn't seem to actually flash anything to the board.

The only other thing I could find to try was to update the firmware, but I was hesitant because of all the issues I found in the forums. To do this, I loaded into BOOTLOADER mode. As the people of the internet collectively predicted, the board would not exit this mode even after power cycling. I downloaded the appropriate .bin file named 0244_k20dx_bootloader_update_0x5000.bin. When the board reset itself, it had exited BOOTLOADER mode (which the internet also collectively predicted), and the board was now named MAINTENANCE. I then updated the firmware using a file named 0253_k20dx_frdmk64f_0x5000.bin. Then when I power cycled the board, instead of showing up as MBED, the board was called DAPLINK. So something happened.

I then tried to download the Hello World program, but every time I try, I see the same two files: DETAILS.TXT and MBED.HTM after the board resets.

Right now the behavior of my device is as follows:

  • When I plug in my board, the green light will be solid for a second, followed by a series of short blinks. My laptop recognizes something was plugged in, and a File Manager window will pop up with the name DAPLINK. There are two files: DETAILS.TXT and MBED.HTM. After this the red LED will blink about once per second.
  • If I try to download a Hello World program, the green LED will flash a few times, and the red LED will give one bright flash. After a couple seconds of intermittent green LED flashes, neither indicator LED will flash. The yellow light on the Ethernet socket will stay on. I'm assuming this indicates that the board is powered and is unrelated to my problem.
  • Pressing the reset button at this point will flash the bright red LED, then the red flashing will occur once per second indefinitely.
  • Attempting to download another .bin file will bring the board back into the state described by the second bullet point.
  • Using the bootloader and firmware update binaries will take them back to their behavior described above (e.g. after downloading the bootloader binary file, the board will go back to the maintenance state, and after downloading the firmware update binary file, the board will go back to the "DAPLINK" state.)
  • Power cycling the board (unplugging and plugging back in) will put the board into the state described by the first bullet point.
  • Holding the reset button while plugging the board in MAINTENANCE mode. The green LED is on and solid. In this mode, the reset button doesn't do anything. Even the red LED will not light up. Power cycling will put the board back into the state described by the first bullet point.
  • All of this behavior is repeatable and predictable as described above.

So a couple of specific questions for you:

  • What do my error LEDs mean?
  • The board seems responsive to the firmware update, so it seems like I should be able to use this board (i.e. the board isn't "bricked"). What do I need to do to get it working?
  • Did I totally forget a step, or make some sort of flagrant error?

Thank you for taking the time to help me out.

I figured out what was going on. I followed the above process correctly, but the newest mbed libraries included in my source code were incompatible with my board. I reverted back to a library from August 2016 and everything worked exactly as expected. None of the current "mbed" or "mbed_os" libraries worked on my board. I'll look more into that problem and keep you updated.

posted by Bryan Redd 08 May 2019
Be the first to answer this question.