Report
2 days, 17 hours ago.

Online compiler nRF52-DK does not compile BATTERY TEST EXAMPLE

Just want to report online compile can not compile BLE BATTERY test example (mbed-os). Thank you. Peter

Comment on this question

1 Answer

2 days, 16 hours ago.

Hi Peter,

I just compiled mbed-os-example-ble-BatteryLevel project by online compiler, and it compiles successfully, is that the project your were compiling with?

What's the failure message you got? Would you be able to share the scree shot or messages?

Thanks,

Desmond

I get just two lines:

Error: The build system did not finish successfully. Info: Unable to download. Fix the reported errors...

posted by Peter Kmet 17 Apr 2019

Does this only happen in the specific project and platform?

Could you use the "Revision" tab to check what's the version of Mbed OS? Try to update it to the latest.

posted by Desmond Chen 17 Apr 2019

Desmond -

I have been having a similar problems compiling for NUCLEO_F411RE board using the online compiler. I have seen the same behavior for several different small test programs starting from a clean "blinky" example. mbed-os is at revision 0063e5de1, which shows to be the latest. I have not tired other platforms.

I make some edits and try to compile. The compilation fails and gives the error

Warning: L3912: Option 'legacy align' is deprecated. Unable to download. Fix reported errors…

The compiler won’t show me the location of the actual error in my code. The warning symbol is not the yellow triangle that I am used to seeing for warnings. It is a red circle with a dash in it. If I just click "compile" again (with no edits to the code), the project compiles and downloads the binary successfully.

I have also had the same problem as Peter Kmet and received the same error message. Compiling again without changing the code successfully produces a binary.

The compiler acts like something is timing out before the build completes - completing the build if I compile a second time.

I have also been experiencing a lot of timeout problems trying to download or import zipped libraries (eg. the mbed-dev source code). This has been reported by other users. In the case of the mbed-dev library, I can successfully download the .tar.gz version but not the .zip version because your server times out. Note that speed tests on my internet connection show download speed of about 120 Mbps. I am also unable to import the mbed-dev library into a new project because your server times out.

Suggestion: try using the online compiler from outside of the mbed internal network (eg. using a personal mbed account set up through your own internet provider). This may help you see the problems that your users are experiencing.

posted by J Roth 17 Apr 2019

Hi J Roth,

I tried blinky example + NUCLEO_F411RE, the issue is able to be reproduced, I will report this internally.

Thanks for reporting this.

Desmond

posted by Desmond Chen 18 Apr 2019

To post an answer, please log in.