1 year, 11 months ago.

Mbed CLI can't find executable for gcc_arm.

Hi, I have a problem compiling in mbed CLI. That's what i do: I first use mbed new. command inside my directory Next: mbed detect Next: mbed target NUCLEO_F446RE Next: mbed toolchain GCC_ARM Next: (To be sure but I've done it previously) mbed config -G GCC_ARM_PATH "C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\arm-none-eabi" Next: mbed compile And I get this error:

make.py: error: Could not find executable for GCC_ARM. Currently set search path: C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\arm-none-eabi [mbed] ERROR: "C:\Python27\python.exe" returned error. Code: 2 Path: "C:\Users\klachowicz\everyrobot_mbed-master" Command: "C:\Python27\python.exe -u C:\Users\klachowicz\everyrobot_mbed-master\mbed-os\tools\make.py -t GCC_ARM -m NUCLEO_F446RE source . build .\BUILD\NUCLEO_F446RE\GCC_ARM" Tip: You could retry the last command with "-v" flag for verbose output -

So I changed up the path many different times and when I almost gave up and gave the same path I did in the begining it worked. Why did it happen and why it keeps happening?

1 Answer

1 year, 11 months ago.

Hi Kamil,

If you installed arm gnu tools by default path, then you should configure GCC_ARM_PATH as below

ConfigureGCC_ARM_PATH

mbed config -G GCC_ARM_PATH "C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin"

Those executable binaries are in this folder.

Please let me know if you have any questions!

- Desmond, team Mbed

Accepted Answer