2 years, 10 months ago.

BLE Nano 2 Failed in discovering services

I recently moved from BLE Nano to BLE Nano 2 and I'm using mbed.org as my development platform. I was able to make the blinky work, but my attempt to use BLE kept failing. I have downloaded several sample code from the template, use nRF-DK52 as the platform (according to https://github.com/redbear/nRF5x/blob/master/nRF52832/docs/Mbed_IDE_User_Guide.md) . I was able to get the BLE to advertise, but every attempt to connect (using Android's nRFConnect) stopped in "Discovering Services". I also noticed that P0_11 internal led stopped blinking, which tells me the program somehow hang.

Separately, In an attempt to debug this, I tried to use printf to the console, but I didn't see anything come out whether using putty at Windows or screen at Linux. The same method worked for BLE Nano v1.

Any thoughts/suggestions?

Switch to use Arduino and it works fine. I noticed there is one case in Arduino that discovering service failed, and it turned out it's the timing between Ticker and the loop(). So this problem seems related to timing.

posted by Kunta H 24 Apr 2018
Be the first to answer this question.