Report
1 year, 7 months ago.

Running this on mbed CLI

Hi,

I am testing this board using mbed CLI.

https://os.mbed.com/users/switches/code/PICO_board_demo/ https://os.mbed.com/users/switches/code/PICO_USB_I2C_SPI/

I imported two programs above and ran "mbed compile -t GCC_ARM -m MAX32625PICO", but it says that MAX32625PICO is not supported. If I replace MAX32625PICO with MAX32625MBED, then it works.

It does not have "mbed-os", but has "maxim-dev" instead. Though I can find "MAX32625PICO" from "targets.json", it doesn't seem to allow me to use it.

Can anybody explain this? Moreover, how can I just use "mbed-os", instead of "maxim-dev"?

Question relating to:

MAX32625PICO Programmable Interface Controller

moved the comment to an answer

posted by Greg Steiert 24 Jan 2018
Comment on this question

2 Answers

1 year, 7 months ago.

The library support for this board is still being prepared for release. The development library does not include the CLI tools.

You can build this in CLI by following these steps:

  1. Import the demo program you want to start with (PICO_board_demo or PICO_USB_I2C_SPI)
  2. Create a new project using the CLI command "mbed new"
  3. In the demo you imported, rename the "maxim-dev" directory to "mbed-os"
  4. Copy the tools directory from the mbed-os directory of the new project to the renamed directory from the demo project.

This will put the scripts where they need to be so that you can compile with mbed CLI

Hi, I tried the same thing that you suggested. Although "mbed compile" works for both "MAX32625PICO" and "MAX32625MBED", the latter only works on the physical board "MAX32625PICO". This is really weird.

posted by Jiwon Yune 25 Jan 2018

If I understand this correctly, then support for the PICO is still being worked on.

And once it is done, the MAX32625PICO target will also exist in mbed-os?

posted by Ferdinand Bachmann 04 Mar 2018
1 year, 7 months ago.

Bonjour,

Désolé de répondre en français, mais je suis nul en anglais.

Personnellement je compile avec "Arm Mbed OS developer site" et j'ai le même problème avec la librairie mbed remplacé par "maxim-dev" , il faut également ajouter " la librairie "MAX32625PICO" pour que ça compile.

Avec les autres microcontroleurs de la gamme (par exemple MAX32630) c'est bien "mbed" qui fonctionne.

Si tu as une explication à celà, je suis très intéressé de la connaitre.

A+

Merci!

I think, in order to fundamentally solve this issue, we need engineers at Maxim Integrated take a look at it. Let me contact the company soon, and maybe ask for more coherence.

posted by Jiwon Yune 24 Jan 2018