Report
1 week, 2 days ago.

Serial connection doesn seem to work

Hi everbody,

I having trouble with a serial connection to my new mbed LPC1768. I have tried to make a RPC connection with it, following the cookbook examples, but i can get it to work. When I was looking for the problem, I made a simple serial connection, just copied an example program from the cookbook, which: "Echoes back to the screen anything you type". made the connection with USB using PuTTY on Ubuntu. But this doesn't work either: it sometimes returns characters, but certainly not all off them. can anybody help?

Kind regards, Eelco Dorrestijn.

Comment on this question

1 Answer

1 week, 2 days ago.

Try this example - https://os.mbed.com/teams/mbed_example/code/Serial_HelloWorld/file/e540d7769e69/main.cpp

Thanx Sarah, that works. But I dont have a clue what I did wrong, a new mbed library?? please enlighten me.

posted by Eelco Dorrestijn 14 Oct 2017

Yeah, the cookbook examples are pretty outdated. We have a better review/testing process for our supported Mbed OS examples. Can you please link to the program you used? I've tried to go through and put deprecation notices on everything that I can.

posted by Sarah Marsh 17 Oct 2017

To post an answer, please log in.