2 years, 7 months ago.

Compiler not working ... again

The online compiler is not working again; It gets stuck "initializing".

I sometime got the following messages.

/media/uploads/pampt/prtscr_capture.jpg

and

/media/uploads/pampt/prtscr_capture_2.jpg

ARMmbed really needs to sort these ongoing issues with the online IDE.

Very frustrating. Again.

Just compiled once and got stuck "initialising". Giving up and going shopping.

posted by Neil Quigg 07 Feb 2017

Same problem observed again with the compiler getting stuck "initializing". Service status at http://mbed.status.io/ reports no problems but the metrics are for October; is this working?

posted by Peter Ampt 22 May 2017
Comment on this question

17 Answers

2 years, 7 months ago.

All,

Appologies for the down time. On the plus side it was only the online compiler that was having issues, all code repositories were still available during this time. Some of you have expressed interest in having an offline compilation option, I would like to point you to mbed CLI (https://docs.mbed.com/docs/mbed-os-handbook/en/5.1/dev_tools/cli/ ) ( https://www.youtube.com/playlist?list=PLiVCejcvpseuWWmJc9uELYww-xindjZCH ). mbed CLI is the tool behind the online compiler that we use for compiling your programs. Using mbed CLI you can trivially move programs between your online repos and offline for development. To bring your code down to your computer simply run `mbed import <URL of Program> and the code will be pulled down to your computer. You can use mbed CLI with windows, OSX or Linux, the compilers for GCC, IAR and Keil are all supported, and if you're interested there is even an `mbed export` option that will let you export your program to Keil, IAR, Eclipse and many other IDE's. In addition mbed CLI works with both mercurial (developer.mbed.org) and git repos (github.com).

Again, I appologize for the downtime, and while we hope a similar event does not happen in the future, just in case it does you can use mbed CLI to continue your work without interruption.

Please note that you must commit your changes to your repositories for them to be seen. So it is considered a best practice to always save your code in the online compiler by committing frequently!

-Austin Developer Enablement Lead

When I tried it it did absolutely nothing. It allowed me to select new, then project. Then nothing. I repeated that. Still nothing. I tried clicking on every possible GUI object. Still nothing.

Is this JAVA?

posted by John Winters 30 Apr 2018
2 years, 7 months ago.

Same here. I have trying for the last 1 hour.

2 years, 7 months ago.

Hi all,

Thanks for getting in touch about the issues of the compiler, we have duly noted these, I am trying my best to work with others get this all sorted ASAP, very sorry for the issues this will cause in any developing.

Once I have more I will update you, expect a fix ASAP.

If you would like to look into offline compiling with mbed, please all look at mbed cli: https://github.com/ARMmbed/mbed-cli

Again, apologies.

Regards,

Andrea, team mbed

2 years, 7 months ago.

Internal error occurred. :-(

2 years, 7 months ago.

Sincere apologies for this. Infrastructure and reliability improvements are planned and in fact already underway. Any downtime is certainly a priority for the mbed Web Team to resolve.

In future, we'll be recording and providing more insight on downtime through our status page at http://mbed.status.io/

Best, Phil.

mbed Web Team Technical Lead

2 years, 7 months ago.

Looks like it's online for me. I did have issues last night.

2 years, 7 months ago.

It does not do any of us any good to tell us how to use and off line compiler when we can't even access our files. Lesson learned.After every build I will have to export the files to avoid loss of future access!!!

2 years, 7 months ago.

The very same experience here! Should we collect money to make the servers more reliable?

2 years, 7 months ago.

Got the same problem...really frustrating...

2 years, 7 months ago.

Same here.

2 years, 7 months ago.

Also here. I would be happy if there was a full instruction on how to set up eclipse to compile on my machine. It would give the advantage of real debugging as well.

Trying it right now using this guide: http://www.carminenoviello.com/2014/12/28/setting-gcceclipse-toolchain-stm32nucleo-part-1/ But I can't install ARM plugins. Could not connect to the repository.

posted by Balazs Sari 06 Feb 2017

Let us know how you get on. When I tried it last year I could not resolve issues with MBed libraries, particularly serial port operation.

There is this https://docs.mbed.com/docs/debugging-on-mbed/en/latest/Debugging/offline/ from Jan Jongboom, Not dated so not sure how up to date it is.

posted by Neil Quigg 07 Feb 2017

Again, compiles once and get stuck 'initialising'.

posted by Neil Quigg 07 Feb 2017
2 years, 7 months ago.

same here =(

2 years, 7 months ago.

same here :'( stuck for a long time

2 years, 7 months ago.

Me too.. frustrating. Is everyone else still hanging on 'initializing' or they back up a running again?

2 years, 7 months ago.

me too

2 years, 7 months ago.

same here

2 years, 7 months ago.

Good thing I'm not the only one. I thought it was a problem on my side, but it seems it is their problem. This is really frustrating. They should have made an offline compiler if they can't handle many requests. I hope they fix this problem soon.