3 years, 9 months ago.

CRP DISABLD

Hi,

First of all, I'm really, really new to mbed and to mac OS X so maybe my question is really dumb.

I've recently got my Seeeduino Arch Max and followed every instruction... I think I have...

What did I do:

1. downloaded the latest firmware (.bin file from mbed) 2. Power recycle the board with the reset button pushed, which entered the board in the 'CRP DISABLD' mode... i.e. I can see the firmware.bin file. 3 on my Mac running OS X El Capitan, I openned a terminal window and start writting dd if={........conv=notrunc... and nothing happened.... 4 I tried to replace the firmware.bin file with the new one.... it seemed to work but in the end nothing happend...

So, my choice was to not upgrade the firmware... BUT

now I cannot go back from the CRP DISABLD mode to the MBED mode to download my programs...

one other thing, before trying to upgrade the firmware, I tried downloading a program and I got a 'not enough disk space' error message, which BTW surprised me a little bit.

If somebody would please point me in the right direction, wether to restore the MBED, restore or uprade the firmware or anything that enables the Arch Max board to properly work?

Thank you in advance

Question relating to:

The Arch Max is an mbed enabled development board for rapid prototyping. It's based on a STM32F407VET6 microcontrolle with an ARM Cortex-M4F core running at 168MHz. It includes an open ...

Ok, Finally it occured to me to use a VM using Win10.... I solved the issue....

Maybe things should be pretty much straight forward using mac or linux... and again, this comment is comming from someone who does not know much about commands in terminal....

thank you for your time Yihui Xiong!!

posted by Francisco Pizarro 20 Jan 2016
Comment on this question

1 Answer

3 years, 9 months ago.

Did you restart the Arch Max board after running the dd command?

sudo dd if={/path/to/new_firmware.bin} of={/path/to/firmware.bin}

Replace {/path/to/new_firmware.bin} and {/path/to/firmware.bin} with the right paths in your system.

Hi, and thank you for your quick response.

If you mean restart the board by unplug it from the USB Power and then plug it again, then my answer is yes, several times, but since last night, the only thing appearing in my mac is 'CRP DISABLD'.... it appears that I've killed the MBED drive....

OK, I'm trying again but still nothing...

/media/uploads/pistolero992000/terminal.jpg

This is a screen captue of what I'm trying without results... I definetely don't know much about mac commands in terminal so maybe and most probably I'm doing something wrong...

Please advice!!!

and sorry for the inconvenience...

posted by Francisco Pizarro 20 Jan 2016

Did you solve the problem? The disk is mount at /Volumes. Do not umount it. It should be

sudo dd if=/Desktop/firmware.bin of=/Volumes/CRP\ DISABLD/firmware.bin conv=notrunc

posted by Yihui Xiong 21 Jan 2016