4 years, 2 months ago.

Code Problems

Hello:

I am trying this code on a ST Nucleo (F103RB), but I am not sure if it is working for me. I am not getting any debug messages through the serial port! I tried the ping-pong code for the same SX1276 module and it works like a charm. I tried changing the code to just do a while loop and send a debug message, but I am still not getting anything! Any tips on how I can debug this? Thanks!

Question relating to:

LoRaWAN Class A node example based on IBM LoRa MAC in C (LMiC) implementation

I downloaded the code for IAR and stepped through the program. It seems the system is getting stuck setting the clocks (I get stuck at HAL_RCC_OscConfig).

posted by Eduardo Garcia 12 Nov 2015

Hi: I seem to have found a solution! What I did was to update the mbed library of the project (I did this by clicking on the mbed component of the LoRaWAN-lmic-app project (it looks like a gear) and under "Library Build Details" to the right there will be an update button!

posted by Eduardo Garcia 12 Nov 2015
Be the first to answer this question.