6 years, 2 months ago.

FRDM-K20D50M connected first time, bootloader download seems not to work

Hello,

I tried to make a FRDM-K20D50M board available for mbed but it didn't work. I proceeded as described here: https://developer.mbed.org/handbook/Firmware-FRDM-K20D50M

I logged in and downloaded k20dx128_k20d50_if_opensda.s19 (save target as...), it is 95.3kB long. Suggestion: Please mention that logging in is necessary to see the corresponding link.

I opened the board in Bootloader mode and copied the file onto it (drag'ndrop), and it obviously was stored there. This was the very first time the board was powered after I have received it. After power cycling the board "appeared dead": No lights were blinking any more and the board was not visible as storage device.

I once more opened the board in Bootloader mode, thought having done something wrong. The device appeared as "Bootloader" storage device, the other files were still there but the k20dx128_k20d50_if_opensda.s19 had disappeared. I once more copied it and power cycled the board, but the same happened (nothing visible happened) as before.

Have I damaged the board? What can I do next?

Thank you in advance, Helmut

P.S.: The board looks VERY interesting (powerful MCU, large flash) and I do not want to loose it.

1 Answer

6 years, 2 months ago.

Hello,

I have seen the same behavoir trying to update a board from a Windows 8.1 PC. After that I used a Windows 7 machine and it worked fine. So I think you don't have damaged your board, it seems to be a USB related problem.

Accepted Answer

This is indeed the most likely explanation. Windows 8.0 and earlier should work. Blame Freescale for still delivering these with an outdated bootloader. Once you added the latest mbed bootloader on it it will work fine under windows 8.1.

posted by Erik - 12 Dec 2014

Thank you very much (Danke, Frank!), it helped. Obviously this does not influence "normal" usage of this board under Win8.1

posted by Helmut Stettmaier 12 Dec 2014