7 years, 1 month ago.

Getting Serial Port to work on Windows 8 connected to NUCLEO-F103RB

It is not working. I have closed all the Explorer windows and even disconnected the USB drive using the connection tray icon. What ever I try I always get the message box headed "mbed (x64)" followed by the text... "The driver could not be installed. No mbed Microcontrollers were found" with the "Install" cancel "Cancel" buttons at the bottom. I've tried rebooting and running different programs on the target, including ones that stream out characters with no effect.

I have a newish dell running Windows windows 8.1. The drive mode is working fine as my modified blinky program can be seen to be working with the led.

Maybe I need to change one of the connectors on the board to enable the serial link but if so I can not see which one.

Please help.

Mark

Question relating to:

1 Answer

7 years, 1 month ago.

Nucleo devices use different drivers, see: https://developer.mbed.org/teams/ST/wiki/Nucleo-Firmware

Accepted Answer

Wow, yes that worked a treat, cooking with gas now!!! Thanks!!!

posted by Mark Norman 29 Nov 2014