4 years, 6 months ago.

FFT Assembly Code Not Compiling

I recently tried to recompile my project which builds off of the code by James Cobb here: https://developer.mbed.org/users/jcobb/code/audio_FFT/

The last time I compiled it was about a week ago. When I tried last night, I got errors in the FFTCM3.s assembly file. The errors I'm getting are all the same: Error: A1185E: Symbol missing in "FFTCM3.s"

I get that error 9 times. I know nothing about assembly, but I do know that I didn't modify the file at all and that it was compiling last week. It's not urgent or anything. I just wanted to know if there was a problem with the compiler.

1 Answer

4 years, 5 months ago.

Hi Ankit, if you're working on the LPC1768: the code compiled when I commented out the preprocessor commands "IF:DEF:TARGET_LPC1768" and the parts designed for other platforms (i.e. the code between ELSE and ENDIF), in the macros MULCC1 and LOADCF, so that only the instructions designed for the LPC1768 would be compiled.

Also, change the MYRBIT instruction to RBIT.

Accepted Answer

Thank you very much Boyuan! That fixed the issues. I'm getting a warning about the RBIT macro, "Macro cannot have same name as a directive or instruction." It probably isn't a big deal. I'll test out my code later.

posted by Ankit Patel 06 Jul 2015