Report
4 years, 10 months ago.

Compile error for Xadow m0

Am trying to compile for the Xadow m0 and getting the following error:

Error: "/extras/mbed_6213f644d804/TARGET_XADOW_M0/TOOLCHAIN_ARM_MICRO/LPC11U35.sct", line 4 (column 9): Error: L6235E: More than one section matches selector - cannot all be FIRST/LAST.

Question relating to:

mbed official / mbed Featured
The official mbed C/C++ SDK provides the software platform and libraries to build your applications.

Hi there, are you using mbed-src or mbed library. If mbed lib, what revision?

posted by Martin Kojtal 10 Aug 2014

Hi Martin, mbed lib - revision 87

The sample code here for example does not compile with the new revision: http://mbed.org/teams/Seeed/code/xadow_m0_blinky/?platform=Seeed-Xadow-M0

posted by Haiyan Zhang 10 Aug 2014

Updated:

There is another bug - the online compiler outputs a invalid binary without a checksum code for Xadow M0. Before we get these bugs fixed, please use http://mbed.org/platforms/TG-LPC11U35-501/ as the target.

posted by Yihui Xiong 13 Aug 2014
Comment on this question

2 Answers

4 years, 10 months ago.

Hi Haiyan,

I got the same error when updating to the latest mbed lib (revision 87). When switching to revision 86, it is ok. You can use mbed lib revision 86 at the moment. Sorry for the inconvenience.

I will track the issue and try to get it solved.

Yihui

Hi Yihui,

This is probably same issue which nRF51822 variant targets had. You can refer following fix.

https://github.com/mbedmicro/mbed/commit/4cb75a3fbb083ffd4a56484a93c5daf0fe3218fd

Regards, Toyo

posted by Toyomasa Watarai 11 Aug 2014

Hi Toyo,

Thanks. I think it's the same. That's helpful. It seems mbed build scripts has changed. Creating a new TARGET_NEW by inheriting a TARGET_ORIGIN in workspace_tools/target.py will get this issue. The build scripts will generate TARGET_NEW and TARGET_ORIGIN folders with the same contents. It's likely the reason of this issue.

Best, Yihui

posted by Yihui Xiong 11 Aug 2014
4 years, 9 months ago.

Hello Yihui,

Did you get this working? Is this the code related to making GATT calls from a Zadow controller connected to a BLE device? I'm trying to figure out how to get a Zadowm M0 controller to advertise itself correct using GATT to an iOS or Android device. Can you help shed some light in this area?

Hi Enrico,

The compile error bug is fixed in the latest mbed library.

Are you using a Xadow M0 and a Xadow BLE to communicate with an iOS or Android device? If it is the case, we can use AT command to set the Xadow BLE as a slave, then iOS or Android can connect the slave device and exchange data with it, the Xadow M0 can read/write data through the UART which is connected with the Xadow BLE

posted by Yihui Xiong 28 Sep 2014

Hello,

I see so you are setting it up for serial data transfer.

I was after getting the embedded device to act as a GATT client. Is this possible?

posted by Enrico Gi 28 Sep 2014

To post an answer, please log in.