6 years, 9 months ago.

Exporting to GCC ARM Windows problem

I am trying to get the GCC ARM offline compiler to work on windows.

I have tried two different methods:

1) Cygwin

2) CMD with GNU make installed.

I have downloaded the GNU Tools for ARM Embedded Processors from the website https://launchpad.net/gcc-arm-embedded and installed that, and add it to the PATH in each method.

In both of them, I get the following output:

$ make
arm-none-eabi-g++ -mcpu=cortex-m3 -mthumb -c -Os -fno-common -fmessage-length=0 -Wall -fno-exceptions -ffunction-sections -fdata-sections  -DTARGET_LPC1768 -DTARGET_M3 -DTARGET_NXP -DTARGET_LPC176X -DTOOLCHAIN_GCC_ARM -DTOOLCHAIN_GCC -D__CORTEX_M3 -DARM_MATH_CM3  -std=gnu++98 -I. -I./mbed -I./mbed/TARGET_LPC1768 -I./mbed/TARGET_LPC1768/TOOLCHAIN_GCC_ARM  -o main.o main.cpp
arm-none-eabi-g++.exe: error: CreateProcess: No such file or directory
Makefile:39: recipe for target 'main.o' failed
make: *** [main.o] Error 1

It is successfully finding arm-none-eabi-g++.exe, as when I don't include its location, it says command not found.

I have done a lot a web searching and other people usually don't have the g++ part of gcc installed, but Cygwin says I do.

It is the simple LED blinking program, exported from the online compiler.

Any help is much appreciated.

Edit:

This is my path:

$ echo $PATH
/usr/local/bin:/usr/bin:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/Program Files/WIDCOMM/Bluetooth Software:/cygdrive/c/Program Files/WIDCOMM/Bluetooth Software/syswow64:/cygdrive/c/Program Files/Microsoft SQL Server/110/Tools/Binn:/cygdrive/c/Program Files (x86)/Microchip/xc32/v1.21/bin:/cygdrive/c/gcc_bin

The arm gcc files are in c:\gcc_bin.

$ arm-none-eabi-g++
arm-none-eabi-g++.exe: fatal error: no input files
compilation terminated.

Thanks,

Adam.

What's in your path, can you share that information? Leave only ARM GCC path there (in my case it's C:\Program Files\GNU Tools ARM Embedded\4.7 2013q3\bin), and try again.

what does display if you invoke only arm-none-eabi-g++ ?

posted by Martin Kojtal 10 Dec 2013

I have added the info you wanted

posted by Adam Osborn 10 Dec 2013

1 Answer

Adam Osborn
poster
6 years, 9 months ago.

I made a mistake somewhere along the way, and reinstalling the GNU arm tools and applying the correct path fixed it.

Accepted Answer