10 years, 1 month ago.

NetServices not compiling

Having lots of trouble getting a new (from scratch) program to compile using segundo NetServices. 1. I start with a clean Program, nothing changed from default, then import latest segundo NetServices. 2. Try to compile but get a missing rpc.h error. 3. Downgrade mbed llibrary to 26 Oct 2012 revision and rpc.h error goes away 4. Recompile then throws 4 "undefined symbol" errors


5. I can Import an existing program that uses the same version of NetServices (TwitteringBilly, for example) and it compiles without error. I can even heavily modify the program without it breaking.

Can anyone help get this to compile? or can someone suggest an alternative library/ies to use to get HTTPClient (with setRequestHeader)?



2 Answers

10 years, 1 month ago.

"missing rpc.h error."

Use the search function of this site. Then you can find this:


Thanks. I failed to mention that I had tried that earlier, and then I get "Namespace mbed has no member rpc", using the most recent mbed library. That's why I tried with an earlier revision of mbed library. As I said, I was able to use someone else's program (TwitteringBilly) that compiled, so I tried to recreate that same program from scratch, using the same libraries and versions.


posted by Joe Bossalini 13 Oct 2013

Check that you have RPC, not rpc:


class RPC {


RPC(const char *name = NULL);

virtual RPC();

posted by Compass Developer 13 Oct 2013

Eero, I really appreciate your assistance. I am using the same mbed-rpc revision you mentioned.

I've been looking at a number of different libraries over the last 24 hrs and am realizing that it will probably be easier to just build what I need (PUT and setRequestHeader) using TCP sockets.



posted by Joe Bossalini 13 Oct 2013
10 years, 1 month ago.