7 years, 11 months ago.

Serial PC no display. Help !

Help !

My configuration : Win7 x64, google chrome, lpc812Max with the latest firmware, mbed ok.

Using serial pc :

No problems with the hardware, the driver is installed and the configuration of the serial port is :

COM5 / 57600 Baud ( I 'v try 9600 Baud before )

I'v done all these things : reset and restart, changing usb cable, disable firewall.

Unable to display something on these terminals : putty, extraputty, realterm, Tera term.

Only one message from putty : " Error reading from serial device"

/media/uploads/vuzzx3/devicecom5.jpg

/media/uploads/vuzzx3/putty.jpg

/media/uploads/vuzzx3/realterm.jpg

/media/uploads/vuzzx3/teraterm.jpg

Thanks.

3 Answers

7 years, 11 months ago.

Have you made the required hardware modification described here. The serial port wont work without changing jumpers SJ1 and SJ4. Dont bother to try and reuse the tiny 0 ohm resistors. Just remove them with a small tipped soldering iron and make the new jumper bridges by placing a small blob of solder.

7 years, 11 months ago.

Verify COM5 port in device manager: "mbed Serial port".

PC terminal: set configuration "Flow control" to NONE.

Blue LED D5 "USB Com" must blink on every input char (from keyboard) or output char (from LPC812-MAX).

code example

Serial pc(USBTX, USBRX);  // serial tx, rx via on-board virtual COM USB port (SJ1, SJ4 = 1-2)

int main() {    
    pc.baud(57600);  // data rate 57600 Baud
    wait(0.1);  // serial clock stable
    pc.printf("\r\nHello World from LPC812-MAX.\r\n");

    while(1) {
    ...

7 years, 11 months ago.

Thanks Wim, I'v been afraid to do that, it's very small, but now I have no choice. Thanks for your fast answers.

If you dont feel confident to make the modification yourself then you may want to ask for some help from someone more experienced. I recommend you do some practicing first on junk smd hardware before attacking the lpc812 in case you dont have much experience.

This is what it should look like:

/media/uploads/wim/img_2906_-_copy.jpg

posted by Wim Huiskamp 06 Oct 2013

Hello,

I made the change as you said, but none of the programs work, and the famous test blink too, the card has all the lights on, and recognized in the PC, no problem, but no reactions, except at the beginning of the Tera Term : <aaaaaaaaaaaaaaaaa> and after nothing, lpc812 is it really dead?

The 3 LEDs react when I download programs.

Thanks.

posted by Brodar Frederic 23 Oct 2013

It works : Hello world !

I configure Putty and I did a reset, which I had forgotten before.

No problems, false alarm.

posted by Brodar Frederic 23 Oct 2013