6 years, 1 month ago.

fail.txt -> TIMEOUT ???

Hi!

I put your Firmware on the device. And modified the Resistors on the LPC812_max.

When I plug in the Device I see the mbed-"drive". so I tried putting your "HelloWorld" on it. The red LED blinks like forever. When it stops blinking the board remounts to the system and there 2 files one is the mbed.htm and the other is the fail.txt with "TIMEOUT" in it.

It's all the same for win7, winXP and Linux.

When I try to flash from LPCXpresso it gives me:

Ni: LPCXpresso RedlinkMulti Driver v6.0 (Sep 17 2013 18:03:45 - crt_emu_cm_redlink build 244) Pc: ( 0) Reading remote configuration Nc: Looked for chip XML file in /usr/local/lpcxpresso_6.0.2_151/lpcxpresso/bin/LPC812.xml

Nc: Looked for vendor directory XML file in /usr/local/lpcxpresso_6.0.2_151/lpcxpresso/bin/NXP_directory.xml

Nc: Found generic directory XML file in /usr/local/lpcxpresso_6.0.2_151/lpcxpresso/bin/crt_directory.xml

Pc: ( 5) Remote configuration complete Wc: ================== SCRIPT OUT ================== Os: Simple flash connect script Index = 1 Manufacturer = MBED Description = MBED CMSIS-DAP VID = 0D28, PID=0204 Path = /dev/hidraw0

1 RedlinkAPI: Probe not open RedlinkAPI: Probe not open Wc: ================== END SCRIPT ================== Xe: Ed:02: Failed on connect: Ee(36). Could not connect to core. Et: Emu(0): Conn&Reset. Was: None. DpID: 00000000. CpuID: 00000000. Info: (null) Error 0: (null) Last sticky: 0. AIndex: 0 No MemAp selected Pc: (100) Target Connection Failed

So what did I wrong? btw. it's my first MCU.

Greetings odo2063

Question relating to:

Comment on this question

3 Answers

e s
poster
6 years, 1 month ago.

OK, the LPCXpresso Problem, was a Userrightsproblem.

6 years, 1 month ago.

Can you try another PC and/or another USB cable?

6 years, 1 month ago.

Can you try the following steps:

  1. Remove LPC800-MAX from any application circuits
  2. Restore the HDK firmware image (suggest using the Win7 box)
  3. Try downloading Hello World again
  4. Post results

Hi!

So i tried as told and with a different cable and a different PC.

Still the same Problem with copiing to the mbed-drive.

posted by e s 08 Oct 2013