8 years, 4 months ago.

Printing to PuTTY window on Linux Mint OS

Ladies and Gents,

I currently have a Linux Mint OS and I have my LPC1768 board connected via USB.

When I do 'ls /dev/ttyACM*', I get

/dev/ttyACM0

When I run PuTTY, I have to run it with sudo. I set up my connection as /dev/ttyACM0, baud=9600, data_bits=8, stop_bits=1, parity=1, Flow_control=XON/XOFF (as opposed to RTS/CTS).

The screen comes up blank and holds there...as expected. When I run a simple "hello world" binary on the board, I see no output, just a blinking LED.

The code example is...

  1. include "mbed.h"

Serial pc(p9, p10); DigitalOut led(LED1);

int main() { pc.baud(9600);

while(1) { pc.putc('m');

led = 1; wait(0.5);

pc.printf("Hello World");

led = 0; wait(0.5); } }

Why do you suppose I can't see the "Hello World" text coming across the PuTTY???

Your help is much appreciated.

1 Answer

8 years, 4 months ago.

I use PuTTY on Windows to read the MBED serial and I have set Parity to "None". Otherwise the same (apart from the serial port of course).

I have Linux Mint on my laptop at home. Later on, I will install PuTTY on that and try it there!