Windows serial configuration

23 Nov 2012

Hi all,

I'm new to mbed and I used my mbed LPC 1768 for my final year project.It was ok with USB communication through virtual serial port in windows 7 (64 bit) after installed the Windows serial port drivers.

But after i formatted my PC and installed the same copy of the windows 7(64 bit) again and installed the Windows serial port drivers' latest updates, it is installing completed.

/media/uploads/harshanaousl/001.png

But not showing serial port in tera team.

/media/uploads/harshanaousl/002.png

In device manager, it is in "other Devices" as follows.

/media/uploads/harshanaousl/003.png

So i can not link the serial port communication with my c++ program as could not find the serial port which communicate with mbed.

Pls help. i'm on the edge of the project demonstration dead lines.

sorry about my english.

Thank you very much.

Regards,

Umesh

23 Nov 2012

Hi Umesh,

I'm not quite sure what has gone wrong with your setup, but I had something similar with my mbed on Win XP and I share my experience in case it may help.

The problem for me turned out to be that I had two mbeds and each one requires the serial debug to be installed on the PC or you get precisely what you are seeing. I had exactly the same symptoms with my second (not previously used) mbed.

Have a look at https://mbed.org/forum/helloworld/topic/4009/?page=1#comment-19901

I realise that you do not mention 'two' mbeds, but as the symptoms are the same I suggest you check/reinstall the serial debug driver as per http://mbed.org/handbook/Windows-serial-configuration.

Let us know if this helps?

23 Nov 2012

This post may also be of interest... https://mbed.org/forum/bugs-suggestions/topic/4132/

24 Nov 2012

Thanks kevin...

I did not mention two embeds. Actually i have only one. I'll try it and reply you.

Thanks again...

24 Nov 2012

Hi kevin..

All methods u suggested were not worked. I also tried ghost removing. it was also not succeeded.

Pls advice... Regards, Umesh

24 Nov 2012

Yes, I realise you did not have two mbeds, but the symptoms were the same for me with my second mbed. This indicated to me that the driver was not installing correctly,however have you tried another serial emulator?

I use Tera term as well and don't think I have had problems with it, but it may be worth checking with another emulator.

I did another search, does this help? https://mbed.org/forum/bugs-suggestions/topic/1186/?page=1#comment-5729 Chris' last point is "I'm using mbed on a Win7 x64 machine (as we all do) without any issues, so I guess the problem must come down to certain configurations, options, security levels and so on.", so security may be your next point for investigation.....

25 Nov 2012

I did them all. But did not worked. Now i'm thinking to re install the OS as there are no any option..... I'll send the results....

Thank you very much....

13 Sep 2017

No Items Found.

Please log in to post a reply.