The official mbed C/C++ SDK provides the software platform and libraries to build your applications.

Dependents:   hello SerialTestv11 SerialTestv12 Sierpinski ... more

Issue: Build tab shows 10KB of RAM for the EA LPC11U35 QSB

When I compile projects for the recently supported EA LPC11U35 QuickStart Board, the build tab shows 10KB of RAM. However, the LPC11U35 still only has 8KB of RAM in SRAM0. The additional 2KB is in SRAM1, and as far as I can tell, is not used by the compiler.

3 comments:

07 Jan 2014

Oops, sorry, I confused the microcontroller I'm using in my project (the LPC11U35FHI33/501) with the one that's actually on the LPC11U35 QuickStart board (the LPC11U35FHN33/401). The LPC11U35FHN33/401 doesn't even have an SRAM1, making the compiler's build tab even more incorrect. It should definitely be showing 8KB.

14 May 2014

I am confused with your comment above. So what's the issue here, is it still relevant?

15 May 2014

undefined wrote:

I am confused with your comment above. So what's the issue here, is it still relevant?

Hi Martin, yes it is. When you compile a project for the LPC11U35 QSB, and check the Memory Usage on the Build tab, it shows the RAM usage as being out of 10KB. In fact, the Platform page also lists it as having 10KB of RAM. This is incorrect. The LPC11U3X series only has 8KB of main SRAM just like the LPC11U2X series. There is 2KB of USB RAM, which is separate (and used by the USBDevice library iirc), and some of the chips have another 2KB block in SRAM1, but this chip doesn't.

TL;DR: The Memory Usage statistics and Platform page should be showing 8KB of RAM, not 10KB.