Report
9 months, 3 weeks ago.

Ublox easy-connect and mbed OS 5.10.0

Just tried to update one of my projects to mbed OS 5.10.0 but then the compilation fails after giving lots of warning with this error:

[Error] NanostackRfPhyMcr20a.cpp@1713,7: class 'NanostackRfPhyMcr20a' does not have any field named '_irq_thread'

If I just create a new empty mbed project mbed new test Add easy-connect with mbed add https://os.mbed.com/teams/ublox/code/easy-connect/

toolchain GCC_ARM target ublox_c030_u201

Then when I compile it will fail

Question relating to:

Development team for u-blox positioning and wireless products

Hi. I still really need some help here to be able to migrate to the ARM version. BR, Martin

posted by Martin Giebat 10 Oct 2018
Comment on this question

2 Answers

9 months, 2 weeks ago.

Hi Martin,

Please try adding the Arm Mbed easy-connect library to your project instead of the u-blox one: mbed add https://github.com/ARMmbed/easy-connect

If you specifically need to use the CELLULAR_UBLOX network interface, I will see what needs to be done to update the Arm Mbed easy-connect library.

Please let me know how that goes & please let me know if you have any questions!

- Jenny, team Mbed

If this solved your question, please make sure to click the "Thanks" link below!

Hi Jenny, I am using the CELLULAR_UBLOX so help there would be highly appreciated.Was there a way for me to understand that I shouldn't use the UBLOX easy_connect? /Martin

posted by Martin Giebat 02 Oct 2018
9 months, 1 week ago.

Jenny,

I have a 2nd business case for support of u-blox (SARA-U201 module) via easy connect. Can you let me know the progress in understanding of the needed modifications to the ARM Mbed easy-connect library and the timeframe you would consider making the modifications available?


You need to log in to post a question