3 years, 4 months ago.

Failed to copy .hex file from linux to nRFDK

When I copied the hex file to the nRFDK through USB port, it will copy the file but after resetting he nRFDK I found out that the program did not run (probably copy was not successful, even though there was no error on the screen).

This is a second linux box (as I'm trying to migrate from using my very old netbook as the mechanism to install nRFDK). The same hex file will be successful if I copied from my netbook. (The hex file was actually built in windows machine through the online mbed IDE, but due to other problem I can't copy the hex directly from the windows machine).

I have tried to compare the mount information through /etc/mtab and use /etc/fstab to define the settings with no success. This is the default setting as shown in /etc/mtab /dev/sdb /media/kunta/MBED vfat rw,nosuid,nodev,relative,uid=1001,gid=1001,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro 0 0

I think it is something to do with the setting since it works with another old computer, but I can't figure it out. Anybody has an advice?

Thanks, Kunta

Be the first to answer this question.