3 years, 5 months ago.

Unable to communicate over serial port with FRDM-k64F

Hello, I am attempting to connect to the serial port on the k64F for the purposes of reading debugging information (via printf and the like).

I am following the instructions here: https://os.mbed.com/platforms/FRDM-K64F/#pc-configuration

These instructions state that as I am on macOS, I should see the board under the name /dev/tty.usbmodem . However, I see no device attached here, despite the fact the program I am loading includes the line "Serial pc(USBTX, USBRX);"

Does anyone have some recommendations as to why the device may not be showing? I have tried plugging into both of the USB ports on the board, as well as the usb ports on the shield board I have attached, but have not had any success.

1 Answer

3 years, 5 months ago.

Have you tried updating the firmware on the device?

Instructions can be found here - https://www.nxp.com/products/microcontrollers-and-processors/arm-based-processors-and-mcus/kinetis-cortex-m-mcus/kinetis-developer-resources/ides-for-kinetis-mcus/opensda-serial-and-debug-adapter:OPENSDA?&tid=vanOpenSDA#FRDM-K64F

I have not yet tried updating the firmware, no. The instructions seem to state that I'll need to first update the bootloader, which if I'm correct is not possible without an external debugger or another k64F. I'll try and get ahold of one of these and see if updating the bootloader and firmware helps.

Currently I am unsure of the firmware version on the board, and the bootloader version is not listed in bootload.htm as I would expect it to be.

posted by Tyler Davis 06 Nov 2017

I think that would only be necessary if you have used Windows 10, which it sounds like you haven't. Just continue to step 2 of the update instructions.

posted by Sarah Marsh 06 Nov 2017