Report
3 months ago.

USB MSD does not work on my Freescale boards: can someone verify this?

As title says, USB mass storage devices don't work on my Freescale boards in combination with Windows 10. I tried the same code, that definately used to work, on a KL25Z, K64 and K22 board. And while they behave a bit different (some don't do anything, the K64F eventually gives a popup of an incorrect USB device), not one of them manages to get the USB MSD working.

I have also much older code, where on different PCs on a KL25 the USB MSD does show up. Sometimes. After a while. And then I can once in a while actually open the file thats on there, most times it won't work.

So summary: USB MSD does not work properly on my Freescale boards. USB Mouse example works on every board flawless, so that pretty much rules out bad cables (I did try different cables). The USB MSD program works also perfectly fine on my LPC1768. And I have a Freescale powered board at family where USB MSD is used also, and guess what: It does not work properly anymore ;).

Now in general solutions are of course appreciated. But that might be hard with limitted info what exactly is going wrong. So first the question if you have a Freescale board, can you test if USB MSD still works on your (Windows) PC? And if yes, if you run Windows 10 or an older one?

Here is a USB RAM disk program with latest mbed libraries: https://developer.mbed.org/users/Sissors/code/USBMSB_Ramdisk_kl25z/. You can put this in any board with a USB connector for the MCU itself, it does not require any external components (assuming your board has a USB connector for the MCU itself, like the Freescale boards have).

I tried https://developer.mbed.org/users/Sissors/code/USBMSB_Ramdisk_kl25z/. on k64f, win10 reports that usb is not recognized.

posted by Martin Kojtal 26 Jun 2017

nucleo f429 - same error happens however I saw installing mbed MSD message.

posted by Martin Kojtal 26 Jun 2017
Comment on this question
Be the first to answer this question.

To post an answer, please log in.