3 years, 11 months ago.

STM32F429I-DISC1 - UARTS dont work ??

Hi I m fairely new to development on STM boards. The UARTS on stm32f429i-disc1 pins doesnt seem to work. I have tried all combinations of uart pins available ,to connect to pc using a ftdi usb adapter, but the damn thing will not work. I have also tried changing baudrates, ports and even completely different ftdi usb adapters. Has anyone got the uart pins to communicate with ftdi usb ,on this board ?

Thanks

Hi. Which compiler are you using ? Is it mbed ? What have you tested exactly ? Please post your details of the pins you are using, the code which is not working using the <<code>> and <</code>> tags for proper formatting. Are you not seeing the output data from this STM board to the host PC using Teraterm or similar program ? Start with confirming the proper mbed target board is installed in your account and import the following example program https://developer.mbed.org/handbook/Serial. Be sure to use the proper UART port pins to capture the transmit out data by the external USB to serial dongle. The baud rates must match the mbed source code.

posted by Sanjiv Bhatia 03 Jan 2017
Be the first to answer this question.