4 years, 2 months ago.

mDot EVB hangs when Joining Network

I'm working on designing a program for an mDot EVB to communicate with a public LoRa gateway. I'm planning on using the existing configuration on the device (as programmed through "Configuration Mode" on the factory firmware) and basing control flow loosely on that of this program: https://developer.mbed.org/teams/MultiTech/code/mDot_LoRa_Connect_Example/

When I run the LoRa demo from the factory firmware, I have no trouble connecting and receiving messages, but when I run my custom program, I am unable to connect (even though I was able to with the same program last week). I have also been using a slightly modified version of the third-party program linked above, and it, too, worked properly last week but does not this week.

I've attached a minimal working example to show the problem. When I run it /media/uploads/jwinters/mwe.cpp on the mDot EVB, it prints out:

``` In join loop [INFO] TX Frequency: 912700000 SF: 10 BW: 125 kHz POW: 18 dBm ```

and nothing else. Even "Tried joining" is not printed.

I'd appreciate any thoughts on what might be causing this issue.

We found the solution: we had to switch to old versions of the `mbed` and `mbed-rtos` libraries. In particular, they were versions 117 and 107, respectively.

posted by Joseph Winters 05 Aug 2016
Be the first to answer this question.