Report
3 years, 1 month ago.

cmsis.h not found

I am quite new to this community and maybe this is a trivial issue. Nveretheless, I was not able to solve it:

I am using a lpc1115 board and I tried to compile a simple blinky. After yotta init, and target definition (nxp-lpc111x-gcc), I installed mbed-drivers.

Finally the yotta build resulted in: In file included from C:/Users/juxe/projects/blinky_nxt/yotta_modules/cmsis-core/source/cmsis_nvic.c:31:0: C:/Users/juxe/projects/blinky_nxt/yotta_modules/cmsis-core/cmsis-core/cmsis_nvic.h:35:19: fatal error: cmsis.h: No such file or directory

  1. include "cmsis.h"

then I found cmsis-core-lpc111x and I installed that either. Unfortunately I got the same error again. I see that the cmsis-core-lpc111x directory contains the cmsis.h file, but the mbed-drivers also come up with a cmsis-core directory and in there cmsis.h does not exist.

Any idea why the cmsis.h does not exist in cmsis-core? Any recommendation how to get beyond this issue?

Comment on this question
Be the first to answer this question.

To post an answer, please log in.