Report
3 years, 6 months ago.

Problem with Mbed interface

Hello everyone, before I describe my problem I want to mention that I have tried every solution for dead/faulty mbed interface I found and nothing worked so far. Similarly, nobody seems to have described my problem.

My mbed was working perfectly until yesterday, when after connecting it to a computer, windows file explorer showed that it contains 3 files with strange names (instead of .bin files and an mbed file which were on it earlier). I was unable to edit or delete these strange files, or add any new files. Reconnecting it to the computer helped, but this situation happened a few more times and finally, it stopped working completely.

Now, when I connect it the blue light goes on after ca. 5 seconds (it used to turn on immediately), and the computer says that I have to format it. However, when I’m trying to do that, after 2 seconds Windows tells me that it was unable to format. I’m also unable to format it with other programs, which either show that they failed or that the drive is read-only. Only Bootice showed that formatting was successful, but in fact nothing has changed. On the other hand, most tools that I tried detect Mbed’s size (2 MB) and name („Mbed microcontroller”). It behaves in the same way on all computers. Ubuntu haven't even detected external drive. When I connect it to an USB charger, the light goes on after 5 seconds as well.

I have tried turning it on while pressing reset button, pressing reset after plugging it in, using different USB cables, and many other 'solutions', but nothing has worked yet. I haven’t found such mbed case (device detected and blue light on, but unable to read/write files or format) anywhere on the internet. Therefore, I would be grateful if you could help me get my Mbed working again.

Comment on this question

2 Answers

3 years, 6 months ago.

Ok, which board is this? Have you uninstalled the drivers and re-plugged the board? Something went wacko as you already knew...

Yeah, I forgot to clarify that: my board is NXP LPC1768. I have tried uninstalling the drivers, but it didn't help. I connected it to different computers as well, with the same result. Also as I mentioned the board works improperly (blue light turning on 5 seconds after connection) even with simple USB charger, so It's definitely not a problem with a computer.

posted by Michał Mysior 28 Nov 2015
3 years, 6 months ago.

If you see strange files...your fat system is damaged. As you have a Ubuntu (no need of special drivers ) , look at https://developer.mbed.org/cookbook/deadmbed and follow the instructions for a Linux user:
Open a terminal
1) check with fdisk that there is NO partition. It is possible that one of your tools has created a partition.
2) reformat with mkfs.vfat
I needed this procedure more than once !

Unfortunately, the 'strange files problem' happened only a few times, and I was able to fix it be re-plugging the board. But then it broke completely and I'm unable to see/access any files at all (Windows says that it needs to format the drive, and Ubuntu doesn't see it at all).

posted by Michał Mysior 28 Nov 2015

To post an answer, please log in.