3 years ago.

stuck at bootloader mode

Hi All

i have windows 8.1 and mbed FRDM-KL46Z. I tried to update the firmware by following the steps in file which are

1. Enter bootloader mode

2. Drag and drop the BOOTUPDATEAPP.SDA file to the root directory of the Bootloader "drive".

3. Unplug and replug your OpenSDA board to initiate Bootloader update. Bootloader update should take less than 15 seconds (probably averages 3 seconds).

i have done step 3 however my mbed doesn't respond any more in the original mode and doesn't even power on the LED. it only responds if i go to the bootloader mode. i tried that with 2 boards on windows 8.1 and i got the same status.

can you please help me ?


Ok here is the solution first : go to windows 7 machine and use the board in the bootloader mode second : download BOOTUPDATEAPP_Pemicro_v111.SDA to your board, then unplug and plug again normally third download MSD-DEBUG-FRDM-KL46Z48M_Pemicro_v114.SDA to your board, unplug and plug again normally forth now your are in the normal mode so download your Bin file and enjoy your board :)

posted by Amr Abdelhafez 16 Oct 2014
Comment on this question

1 Answer

3 years ago.

Thanks for sharing the answer Amr Abdelhafez !

To post an answer, please log in.