Report
5 years ago.

Ublox C027 (LISA U20) Firmware and SIM issues

Hello, I am trying two troubleshoot two problems on my recent C027 (LISA, i.e. GSM): 1. On OSX (10.6.8 and 10.9.4) copying bin files (downloaded from the online compiler) to the mounted MBED volume does not always work. If it does work, I do not see the .bin files on the volume the next time it is mounted (unlike my MBED LPC1768 and LPC11U35 which do hold all the binaries and load the most recent that was downloaded).

-When copying (drag-n-drop with Finder or using cp in a terminal) sometimes the drive is unmounted prior to finishing transfer -Even with the preinstalled Nov.2013 firmware, I was able to copy the HelloWorld example, but had trouble when trying to copy SupportTest example. -When I did upgrade to the most recent firmware, I was able to copy over SupportTest initially, but had trouble when I copied over HelloWorld and then SupportTest for a second time. I found the following links helpful for firmware, flashing instructions, and sync mounting options for OSX:

http://mbed.org/users/ublox/notebook/ublox-C027-Update-CMSIS-DAP-Interface-Firmware/ https://mbed.org/users/sam_grove/notebook/cmsis-dap-notes/ http://mbed.org/handbook/Mounting-with-sync

-I tried re-flashing with the most recent firmware and the one from Feb.28 2014 (v2.01) and eventually reverted back to Nov. 2013 version and using a windows box so I could troubleshoot my second issue using the U-Blox m-center software.

-Why can't the C027 show the most recent binaries that were downloaded to the MBED drive (in addition to not being able to copy it seamlessly, which I though the April 2014 firmware was intended to fix for Linux and OSX)?

2. I get a "CME error: SIM Wrong" when issuing "AT+COPS=0" or "AT+CPIN?", what does this mean? -I am using the AT Terminal in m-center software v1.1.0 (after copying over C027_ModemTransparentSerial binary) -I have a goPhone (AT&T US) SIM card installed (verified, using a smartphone, that SIM can register to a network) -I verified that the AT&T has provisioned my account with the SIM Card and LISA-U20 IMEI -On the m-center homepage the SIM status is "-" and security is "Disabled" (I tried setting a pin with my smartphone also, but one entering the same pin using the m-center homepage, was told it wasn't correct) -I do get a response of the available networks when asking for a list of network operators AT+COPS?"

Thanks, akhil

Question relating to:

The u-blox-C027 is a complete starter kit that allows quick prototyping of a variety of applications for the Internet of Things. The application board has a MAX-M8Q GPS/GNSS receiver and ...

I apologize for the unintended formatting of the question and the strikeout of the last sentence (that shouldn't be struck out!)

posted by a s 02 Sep 2014

Please CC me with updates. I am delaying my purchase of EVK-U20 Supports LISA-U200 (Global) / U260 (for Americas) / U270 (for EMEA, APAC) until your issues are resolved by AT&T: mikeflores@tapngo.us

posted by Mike Flores 06 Oct 2014

Could you check if your board flashes and executes the copied .bin file ?

The FRDM-K64F has the same behaviour as you describe. Upon dropping an application .bin file (as obtained from the online IDE compiler) to the USB mass storage drive, the devices realizes promptly by itself this is a new program to flash and to execute. It automatically un-mounts itself, flashes the app, removes it from the mass storage, and resets itself, then starts to execute the newly flashed app. - That's actually very convenient and speeds up edit - compile - test cycles.

posted by Guido Grassel 16 Oct 2014
Comment on this question
Be the first to answer this question.

You need to log in to post a question