7 years, 11 months ago.

FRDM-KL25Z set up for mbed

I have a FRDM-KL25Z, I can go into bootloader mode, copy mbed_if_v2.0_frdm_kl25z.s19 to it - seemingly no problem. But when I disconnect and re-connect the FRDM-KL25Z my pc does not see the drive at all. I'm using a laptop with running Windows7. I've tried copy & paste as well as drag & drop to get mbed_if_v2.0_frdm_kl25z.s19 into the Bootloader, but still no response. What else do I need to do?

Question relating to:

Can you try to use it on the different computer? Does the device manager show anything ? Not installed properly ?

posted by Martin Kojtal 12 Oct 2013

Just tried it on a Vista laptop - same result. Cannot see the FRDM-KL25Z on device manager. I guess there is a corrupt file I can't see, I made a copy of the original files and in an attempt to resolve this problem I have replaced them with these copies - but no change!

posted by Chris Muten 12 Oct 2013

1 Answer

7 years, 11 months ago.

I got the same mbed frdm-kl25z. well my mbed is working perfectly fine.. can u tell me how many files are showing in mbed drive.. there must be some initial files present as well

The files I see in Bootloader mode are: FSL_WEB, LASTSTAT, SDA_INFO & TOOLS

posted by Chris Muten 12 Oct 2013

Cut these files to some other folder !! Then copy mbed_if_v2.0_frdm_kl25z.s19 Into the bootloader !! Then unplug it and plug it again !! Hope it will fix this issue !! N make sure u r plugging ur usb to open sda port

posted by zain aftab 12 Oct 2013

I have the same issue. I cut the files and pasted them elsewhere. When I drag and drop mbed_if_v2.0_frdm_kl25z.s19 to the bootloader, those four files pop up again, but no mbed. I'm running Ubuntu 12.04.

posted by Edwin Bailen 12 Oct 2013

oh now I got it !!! it is mentioned in their site..that linux sometime dont support bootloader update.. u need to update it from windows..

posted by zain aftab 13 Oct 2013

I deleted the 4 files visible in Bootloader, and copied mbed_if_v2.0_frdm_kl25z.s19 into it. When I disconnect and re-connect the drive isn't seen. The only way to see it at all is to go back to Bootloader mode, and then all I can see are the 4 files I deleted when previously in that mode, no sign of the copy of mbed_if_v2.0_frdm_kl25z.s19 - indeed should I be able to see the file mbed_if_v2.0_frdm_kl25z.s19 when I return to Bootloader mode? Device manager shows 'Bootloader' when the FRDM-KL25Z is in Bootloader mode, and nothing when it is in non-Bootloader mode, so I can't get to open sda port mode!

posted by Chris Muten 13 Oct 2013