10 years, 5 months ago.


Hi, I have an XTRINSIC-SENSORS eval board that is essentially a FRDM-KL25Z Evaluation Board with bunch of extra sensors. Unfortunately, it seems that mbed bootloader does not fit to the board. Any suggestions? Thanks

Question relating to:

I followed the instructions and it worked first go.

posted by Very Compact 09 Aug 2013

1 Answer

10 years, 5 months ago.


I was successful in loading the mbed bootloader. Worked second time (haha). Go back over the "how to" instructions, slowly and step by step. See my other notes:


I use the Freescale bootloader for the KL25Z board. It downloads and executes mbed .bin files just fine. However, you have to use the mbed bootloader at least once in order to register the KL25Z with mbed.org


Accepted Answer

I have no joy still... The disc"mbed" does not come up after updating the bootloader. I've tried the latest MSD firmware 1.09 form pemicro.com (both KL25Z and XTrinsic) with no luck.

posted by auPilot auPilot 25 Jun 2013


You cannot install the mbed bootloader file unless you have the BOOTLOADER drive showing on your PC drive map.

Before uploading the mbed bootloader, did you 1. unplug the KL25Z, 2. hold the reset switch while plugging the KL25Z back in and 3. finally release the reset switch? This should give you a drive called BOOTLOADER.

Are you using a Windows machine?


posted by Kevin Braun 25 Jun 2013

that is exactly what i'm doing.

  • I have no problems getting "Bootloader" drive (holding reset) and I can reflash different versions of bootloaders.
  • I have also no probs with getting the original "FRDM-KL25Z" drive in msd programming mode (no reset held). However, once I reflashed the board with MBED bootloader, there is no drive appeared in msd programming mode (no reset held). I still have access to "bootloader" thought, and I can reverse to the original pemicro bootloader.
  • i use Windows 7, but have tried Mac as well.

posted by auPilot auPilot 25 Jun 2013