The FRDM-KL46Z is an ultra-low-cost development platform enabled by the Kinetis L series KL4x MCU family built on the ARM® Cortex™-M0+ processor. Features include easy access to MCU I/O, battery-ready, …

FRDM-KL46Z - broken?

14 Dec 2017

Hey, there. So, I've had this KL46Z in its box for years - since 2013, at least - and just took it off the shelf, today, to give it a whirl. I plugged a USB cable into the USB port (not the SDA) and it ran through a counter program on the built-in LCD display. I connected the cable to the SDA port and got nothing: no lights, no "MBED" volume in the file manager. I'm consistently able to get it into BOOTLOADER mode, but no matter what file I drop onto it, it won't light up after the restart. I have some KL25s and other mbed modules sitting around and tested those to rule out my laptop: they all worked. It's pretty clear there's something wrong with this module. I downloaded the SDA files from PEMicro and tried one of those: No joy. I'm usually pretty good about static, making sure to ground before I touch things, but it's possible I could've zapped this board. Anyone have any suggestions to resuscitate this unit?

16 Dec 2017
16 Dec 2017

Install the latest firmware from pemicro, as described here:

I think the mbed firmware still has problems, with the pemicro firmware, the board still works. From the bootloader mode, you can only program the firmware, not the actual application.

01 Jan 2018

Sorry for the delay: I didn't get any notices of follow-up posts. Hmm.

Anyway, updating the firmware is where I ran into problems: the firmware upgrade drag-and-drop onto the BOOTLOADER volume didn't work. I tried it on all three platforms: Win 10, Ubuntu and Mac. But I had some difficulties updating the firmware for a couple of new KL05s and resorted to the manual commands as listed here: . I eventually got those upgraded. Using that as a guide, and figuring I had nothing to lose, I ran the following on my Ubuntu host:

 sudo udevadm control -s
 sudo mount -t vfat -o sync /dev/sda /mnt
 sudo cp 20140530_k20dx128_kl46z_if_opensda.s19 /mnt
 sudo umount /mnt
-- disconnect / re-connect the KL46
 sudo udevadm control -S
 -- device "MBED" showed up in the volume list

I just connected the KL46 to my main dev host - a Mac - and the MBED volume shows up. A quickie "blink" test program dropped on to it works, too, so it looks like the KL46 *wasn't* bricked, after all. Phew. Thanks for the suggestions!

06 Jan 2018

Hi Aaron - Glad to hear you got the board working. There are a few things to keep in mind. The bootloader for that board is probably quite old and the only way to upgrade it is by getting an update from PE micro. The interface applications are interchangeable (the bootloader loads this) and from your logs it seems the file you've used is quite old. If you're up for it I'd suggest getting the bootloader upto date from PE micro and then getting the latest build of daplink interface firmware.

12 Nov 2018

Trying to update 3 boards I have without success.

Everything started when I tried to load blinky program on board under W10 and nothing happened. Then I see FW upgrade! Yes this is probably why it doesnt work... I try to update fw from mbed site ->20140530_k20dx128_kl46z_if_opensda.s19, but this only made boards disapear - no LED s nothing... I can only get into bootloader mode.

I tried to update bootloader under Linux but also no avail. (drag and drop)

If I put new PE micro bootloader on my boards and re-plug nothing happens. If I put board again in bootloader state and check bootloader version still says

MicroBoot Kernel Version is: 1.05 Bootloader Version is: 1.09 Application Version is: 0.00

Bootloader I'm trying to load is 1.11 This really sux... I think instructions should be clearer what to do first and on what machine... So instead banging my head programming I'm banging my head on something that should work out of the box....