Damaged LPC1768 & COM3 (TeraTerm)?

11 Jul 2010 . Edited: 12 Jul 2010

I have three LPC1768 modules on my bench. Something has happened to one module in that it no longer shows a COM port when Tera-Term is loaded. (TeraTerm says "Cannot open COM3"). When this first happened, TeraTerm suddenly froze while receiving data. After closing and reopening TeraTerm and resetting the mbed device, the "Cannot open COM3" message first appeared. The rest of the module works OK. I can upload new firmware to the mbed folder and everything else, but I now have no debug output with this module. My other two modules work OK so I don't suspect the PC or mbed USB drivers are at fault.

I reformatted the mbed module according to the thread "Dead mbed?" at http://mbed.org/forum/mbed/topic/399/?page=1#comment-1996. The module reformatted without any problems, accepted and ran new firmware, but COM3 could still not be opened. I've powered down both the PC and the module but that did not help. It's like the hardware handling the USB on the LPC1768 has been damaged. Or, is there an unseen bootloader or monitor in the module which may have been corrupted and in need of reloading, or do you think I have a damaged part?


13 Jul 2010

Try re-running the serial driver installer?

13 Jul 2010

Hi Jon:

Thanks for your response. I downloaded and re-installed the Windows Serial USB driver. Unfortunately it did not make a difference.

That is the strange thing about this problem. I can line up my 3 mbed LPC1768 modules on the bench and plug them in one at a time. The other two modules connect with no problem. When I plug in this third module TeraTerm and DockLite serial programs both cannot find COM3.

I think something is damaged onboard. All other functions seem to work OK. I can download programs, etc. I just cannot get any serial terminal debug info out. Normally I would not be concerned if it were a $2 or $3 part--I'd just throw it away. But at $67/mbed module (DigiKey) I'm more reluctant to do so.

Maybe someon at ARM/mbed/NXP would like to see this part. Any chance of an exchange of parts?


Cannot open COM3

13 Jul 2010

Maybe try and see if you can reflash the interface chip firmware.

13 Jul 2010


Thanks for pointing to the firmware driver. I just tried reflashing it with version mbedMicrocontroller_16457.if, but it didn't fix it. Strange. Serial COM through USB doesn't work, but regular USB does. It does sound more like firmware than hardware. I would think that Serial-COM-over-USB and pure USB would both use the same hardware. Are there anymore low-level firmware modules that I can try?


13 Jul 2010

Hi Doug,

Sorry to hear you are having problems.

The first thing I'd try is rebooting your PC. I know this is a generic (almost laughable) piece of advice, but in this case there is reasoning behind it.

When you open TeraTerm, or any other terminal application it opens a handle to the serial port. If the program terminates unexpectedly, it doesn't have a chance to release the handle (as it does when you close the program or disconnect). When you restarted TeraTerm, the COM port you were expecting to find will have already been allocated to the previous instance of TeraTerm (different Process ID) and so will not be available, and will not appear in the list of available ports.

So, try restarting Windows, and let us know if this solves the problem.


mbed Support


13 Jul 2010

Hi Doug,

I'd also advise you to try the following:

In the device manager, locate the corresponding "mbed Serial Port" device. If you double-click on it, you can go to the "Port Settings" tab, then "Advanced". Here you have an option to change the COM port number. Try to map the mbed to another (free) COM port, and see if it does the trick (as COM ports might sometimes get in conflict between devices).

If that fails, you can try uninstalling the mbed from this device manager before trying to reinstalling it with the serial driver.

Also do you have the option of testing that mbed on another computer?

Have you installed new hardware on your PC or upgraded some drivers recently?

Hope this helps,


13 Jul 2010

Hi Donatien,

Your idea to look through the device manager has helpd to see what is going on. Because I have multiple mbed modules on my bench, and I switch between them regularly, I guess I was distracted by the "Unable to Open COM3" message.

When I plug the suspect module into the USB, and using your suggestion, I find the modules is actually going to COM4. When I bring up TeraTerm it complains about not being able to open COM3, but apparently goes ahead and opens COM4 anyways. Recognizing this, I guess there really is no problem, only an "operator" error on my part.

Problem and mystery solved, Donatien. And thanks to all those responding to this post.