BIN-file not worked on other boad with lpc2368(Ethernet)

10 May 2010 . Edited: 14 May 2010

Hello to all!

I have this board

and this board

My code with class "Ethernet" from library for Mbed worked only on this board


If load bin-file in this board then programm nanged and not worked.

Scheme of other board

10 May 2010

HI Artem,

Looking at the schematics of the other board you have (SK_MLPC2368), the first thing that I notice is that the other board uses a different Phy, the KS8721BL from Micrel, whereas your mbed microcontroller use the DP83848C Phy from National Semiconductor.

While they do the same job, I suspect there might be some subtle differences in how they are configured, which is causing your code to fail.

The Keil MCB2300 board uses the same combination of LPC2368 + DP83848 as the mbed, and I have been able to run the same binary on the Keil board, so the theory of binary portability does work if you have the same setup.

Hope that helps,



10 May 2010 . Edited: 14 May 2010

How I make class "Ethernet" for worked with PHY from Micrel ?

10 May 2010

Start by looking up the datasheet, and read the specs.


/ Lerche

14 May 2010

Can I looking source code of class "Ethernet" ?