Windows 64 compatibility?

24 Feb 2010

I have just started to use a new computer. This runs Windows XP 64.

When I try on install the serial port driver I get a message telling me the program I am trying to run is not  avalid Windows 32 program!!!!

Does this mean that (inspite of the message) I cannot run under Windows 64 or am I missing something else?

I have dual boot into Windows 32 so this is not a major issue but would prefer to be able to run under Windows 64

Thanks for any help or advice

 

Allan

24 Feb 2010

I installed the serial driver on Windows 7 64bit last night and everything seems to work correctly.

The version I used was the most up-to-date from http://mbed.org/handbook/WindowsSerialConfiguration

If you haven't maybe try the most up-to-date driver? Otherwise this may be just an XP problem.

Hope that helps in some way.

24 Feb 2010

Richard,

Thanks for this tip. I am using the version 16446 which i downloaded this morning. I think this is the latest version.

The other thing which may be relevant is that as a consequence of my Dual Boot configuration I am booting from drive E, Could this be significant?

 

24 Feb 2010

Sounds like a corrupted download. Try another browser, or clean the cache and cookies and redownload.

24 Feb 2010

I have cleaned up and downloaded again and got the same results, even when running under Widows XP 32.

On checking I realsied that soemtimes when trying to run I did not have mbed connected.

Just to try everything properly I took my note book which runs Vista 32 bit version and which has never had my mbed connected.

I connected the mbed and down loaded the file. This I stored in a USB memory stick but then copied to the desktop.

I then closed all other windows and programs and with the mbed connect attempted to run from the desktop and got excatly the same message.

Clearly I am doing something really stupid and do aplogise for wasting peoples time but what it is that I am doing wrong?

24 Feb 2010

Very strange. As far as I can tell you're not "doing wrong" anything, but something clearly does go wrong.

What browser are you using? Did you try another one? (e.g. Opera or Firefox if you've been using IE)

Could you post the screenshot of the error message? Also, what's the exact byte size of the downloaded file (check in file's properties)?

24 Feb 2010

Igor,

On both machines IE 8.

I have also tried using XP 32 on my dual boot system with the same results.

The file is 232KB (237,568Bytes)

I will try with Firefox later this evening

24 Feb 2010

The correct size for mbedWinSerial_16466.exe is 594 KB (608 768 bytes). So it seems that somehow your download gets cut short.

24 Feb 2010

Igor,

 

Using Firefox I downloaded a file that is indeed 594 KB so clearly my earliers downloads were being corrupted.

When I run this version it triggers the windows "New Hardware Wizard". I cancelled this which I now suspect was not the ebst thing to do.

At the end the setup program tells me that ran succesfully but Device Manager tells me the device has a problem with its drivers.

Should I point the hardware wizard at the setup program?

Do you still want a screen dump showing the error message ? I can easily ( I hope) repeat the previous failed set up on my notebook.

Thank you for your help

25 Feb 2010

I have successfuly insatlled the driver on the Windows XP 32 bit system so if i boot into that I can communicate with my mbed.

However using exactly the same download file I cannot install the driver into my Windows XP 64. As before the install program tells me it has succesfully insatlled but device manager tell me it has not, nor can I access it.

Any suggestion will be very gratefully received.

26 Feb 2010 . Edited: 26 Feb 2010

I haven't had any problems using it with my new laptop which used Windows 7 x64.

27 Feb 2010

I still cannot make it work with Windows XP 64.

Apart from the new hardware wizard appearing during the installation evertyhing appears correct but the drivers are not loaded

27 Feb 2010 . Edited: 27 Feb 2010

I think I had to load them manually. It was some time ago, though, so I could be wrong. Connect the mbed and remove the old drivers, if any, first. They will show up as having a problem in the Device Manager.

I just checked the Device Manager on my laptop with the mbed connected. It appears under Portable Devices as MBED. One driver is ...DRIVERS\UMDF\WpdFs.dll, the other is ...\DRIVERS\WUDFRd.dll.

27 Feb 2010

Hi Allan,

It sounds like the install has got confused, or there is some incompatibility which we need to track down.

First, i'll assume windows got confused. To start with, can you fully uninstall the mbed drivers; in Device Manager with the mbed plugged in, you should be able to find the "mbed Serial Port" under "Ports" and the "mbed Composite Device" under "Universal Serial Bus controllers". For each, choose uninstall and tick the box that says remove the files. Now, if you disconnect your mbed, with Device Manager open reconnect the mbed, and you should only see a standard Windows Mass Storage device driver load in Device Manager. i.e. no mbed related things, and no hardware wizard poping up or anything.

Ensuring you have the full installer (all 608,768 bytes!), try running this with the mbed connected and nothing else open (not even an mbed drive window). Can you tell us what the results are. i.e. does it progress through the install ok, does hardware wizard pop up, do the serial and composite drivers appear in device manager, which appear to load.

If there are right click options when running a program on x64 (e.g. run as administrator, legacy 32-bit), you could try them. The other alternative is to "unzip" the installer .exe and do a manual install using the x64 composite and serial .inf and .sys files, although I haven't got a machine to write a walkthrough here, so only recommended if you know what you are doing!

If that fails, we'll perhaps get a debug version of the installer to you to see if we can track it down.

I know Stephane had a problem which we finally tracked down to windows having corrupted some of the install files that it moved to it's internal driver store, so it didn't do anything when reinstalling (it thought it had nothing to do), so it never fixed itself until Stephane manually deleted them; Stephane or Chris may be able to capture exactly what the solution was.

Also, can you tell us exactly which version of Windows XP 64 you are using and the hardware you have it installed on. Then, if it comes to it, we can try and recreate the problem this end.

Thanks,
Simon

01 Mar 2010 . Edited: 01 Mar 2010

Simon,

Thanks for this advice. I have followed it and made no progress but have logged my actions and the computer results. Apolgies for it being a bit detailed but I reckoned it is easier for you to skip irrelevant information than ask for clarification.

A Check driver download file size correct, put the simple new program on the embed and remove the old drivers.

B Reboot and login as administrator

C plug in mbed and close its explorer window, the LED flasher is working correctly

D Run driver install programme

E MS window to tell me publisher not verified, pressed “run”

F window mbed(x64) install shows, pressed “install”

G MS window says mbed comp device not passed logo testing, pressed “continue anyway”

H quite fast succession of MS small windows about new hardware, missed the detail sorry

I MBED explorer window appears

J MS window “New Hardware Wizard” appears, pressed “cancel”

K MS window saying driver not installed

L mbed window saying “mbed x64 driver correctly installed

M looked at Device Manager; mbed composite device under USB is OK but under ports is “not configured correctly” and “no driver installed”

N disconnected mbed, rebooted and reconnected, got MS “New hardware wizard” and the same results in Device Manager

· Windows version is Windows XP Professional 64 bit version 5.2 Service pack 2. This is installed on a dual boot system with the boot directory for XP64 being drive E

Processor is Intel 8300, quad 4 core 2 with 4 GB ram, what more information would you like?

 

Thank you for your help and advice

Allan

01 Mar 2010

Simon,

 

Aplogies for the word rubbish at the start of my reply,

 

Allan

01 Mar 2010

"A Check driver download file size correct, put the simple new program on the embed and remove the old drivers."

So you put the installer exe on the mbed drive? And ran it from there? If so, don't do that. Copy installer to your hard drive and run from there.

01 Mar 2010

Hi Allan,

If you plugin the mbed and the hardware wizard pops up, have you tried just going through that and selecting "find drivers on my computer" (or whatever it is called). It could be that the drivers have been put in the right place, but windows has not correctly gone through it's install procedure (every version/vaiant of windows seems different!).

btw. word rubbish removed :)

If that doesn't work we'll have to investigate deeper, so please report back on the results. If Stephane/Chris can also restate the fix that solved the other problem that would be great.

Simon

01 Mar 2010

Simon,

 

That worked thank you.

I asked the new hardware wizard to search for the files on my computerand it found somethat it is happy with

 

Allan

02 Mar 2010 . Edited: 02 Mar 2010

Hello,

In my case, the driver could not install at all on a Windows 7 x64. For some reason it was corrupted in the PNPUTIL driver collection. Chris had me remove both mbed drivers to make it work again. Here comes his e-mail :

--------------

The next step is to remove the dirver from the store. This will force windows to replace it. This is a little more advanced, so please do this ONLY if you are confident, and you will be removing it at your own risk. To remove the driver :

1. Open a Command Prompt window as Administrator (Right click on "Command Prompt" then choose "Run as administrator")

2. Get a list of driver packages in the driver store: pnputil -e

3.  Locate the ones with "Driver package provider: mbed" and note the Published name (oemX.inf). You may only find one, with "Class: Universal Serial Bus Controllers", when the device is properly installed there will also be one for "Class: Ports (COM&  LPT)" too.

4. Force deletion of the driver package with: pnputil -f -d <oemX>.inf Of course, you will need to replace "oemX.inf" with the correct name.

5. Then try running the mbed installer again. If that doesn't work please send the latest log again. The full documentation for pnputil is here:
http://msdn.microsoft.com/en-us/library/ee816995.aspx

 

------------------

It worked great for me (but Chris gave me a newer version of the mbed serial driver : build 17142, it is still 16466 on the mbed web site).

 

I had to redo the install recently. It seems that windows update did something as the drivers were corrupted again.

 

Hope this help

03 Mar 2010

Stephane,

 

Thanks for this information.

My system is now working so I will leave well alone, unless a system update forces me to reinstall.

I noticed earlier a comment by Igor a couple of days ago. I did not make myself clear there. What I meant was that I put on my mbed a program it was running that did not call the USB port, I has considered as a possible cause of trouble my mbed trying to write to the PC whilst the driver was trying to install.

I now think that because of my dual boot configuration the install routine was looking in the wrong place for the files it had created but when allowed to search for them over the whole computer was successful.

Should anyone want more information about this please ask and I will do my best to provide it.

Again my thanks to the people who have helped

 

Allan

11 Feb 2019

Hi All,

I am working on LS1021a board. When I connected the board with windows7 x64 machine the mbed serial port doesn't show up in ports(COM and LPT), But I see mbed composite device listed in Universal Serial Bus controllers.

I installed the driver mbedWinSerial_16466.exe even then it doesn't show up. Can someone help me out in this. I am connected to the board via code warrior TAP.

Thanks Nisar

28 Jun 2019

Although Windows XP, Vista, and 7 all have 64-bit versions available, many companies still opt for the 32-bit versions. The biggest reason for this is compatibility issues with older programs, hardware, and drivers.

___________________

Source: http://mangazuki.me

You need to log in to post a reply