Dead Mbed?

13 Jan 2010

Hello, I'm looking for some advice to bring my mbed back to life. I think there is a problem with the flash and I don't know how to reformat it.

Mbed was working well until my Windows C: drive crashed badly. Windows completely froze and I was in a file transfer to the Mbed at the time.

I restored my Vista system to a new hard drive so the computer is back but Mbed is no longer recognized as a valid drive. I also tried on an XP system and no luck there either so I doubt it is the computer.

Plugging Mbed into the usb port enumerates and shows a drive in  the explorer as expected so it starts up. However trying to open the drive says "The disk in drive F is not formatted. Do you want to format it now?"

Clicking Yes will not format but instead just says "There is no disk in drive F. Insert a disk and try again."

Anyone know what could be wrong?

Thanks in advance,


13 Jan 2010

Try doing the formal while holding down the reset button.

13 Jan 2010

Did you solve the problem?
Othervise you can try this out:

If you're using Vista, try "Repair this device", or something like that, when you plug it in to the computer. . I've tried that on my phone, as I had to remove it from the computer while transferring, and that worked.


13 Jan 2010

No luck with holding the reset while plugging in and I do not see a repair option. It looks like windows (both xp and vista) do not recognize the flash drive anymore. They do recognize the usb connection though. I'll try and link screenshots below of the mbed drive properties on xp.

Is there a hard physical reset sequence I can do that will cause the mbed flash to reformat without requiring the computer to recognize it?



13 Jan 2010

Hi Mike,

Just to be clear, can you try :

- Press and hold reset button down.

- Plug the mbed in to your PC (keeping the button held down)

- When the removable drive appears reformat it (still with the button held down)

- Unplug the mbed

- Plug it back in normally (without the reset button being held)

It is important to keep the reset button held down so that the target is in reset and is unable to interfere with the file syste.

Let us know how you get on with that.



13 Jan 2010

Hi Chris,

Thanks! You nailed it, i didn't hold reset through the entire sequence last time. I think the .bin file transfer was corrupted previously and was somehow causing contention with the filesystem. I'm up and running again.

Thanks again,


06 May 2011

The mbed is not very rugged. My mbed died in an early stage as well. I switched to Arduino, which is very robust with respect to user errors.

03 Aug 2012

I have been having problems with this "dead mbed" effect while experimenting with the local file system and have found the following "quicker fix"!

Hold down the reset button, Windows then recognises the drive as mbed again.

Keep the reset button pressed and compile and download your next 'corrected' code or a previous working code.

When downloaded release the reset button and your code is ready and the file system intact.

17 Aug 2016

I have the same issue with two boards, Delta DFCM-NNN40 and MTS-Dragonfly, persistent on Windows 10. Formatting the drives does not help, it's a Windows 10 issue. It also does not seem to affect several FRDM boards that I have lying around. I have not tested other versions of Windows, but =Ubuntu displays and flashes Mbed perfectly fine. I have resorted to passing control of the board to Ubuntu housed running inside Virtualbox.

17 Aug 2016

The Windows 10 Anniversary edition has broken STLink, so any board with ST silicon (like Dragonfly) is unflashable on Windows 10 right now... We're working with ST to get this resolved as soon as possible.