Problems compiling previously compiled code

25 Jun 2012

Hi all,

Compile some code that compiled fine at the end of last week (Friday). Today I'm getting the following problem listed in the compiler output. There's no line or file listed so not only am I not sure what the problem is, I don't know where that problem might be.

'More than one section matches selector - cannot all be FIRST/LAST." in file'

I'm presuming it's something stupid on my part.

I'm in beta mode.

Joe

25 Jun 2012

Hi Joe,

Can you tell me whether the problem occurred right after enabling betamode, or afterwards?

That error message usually means that there is more than one mbed library in your project, or that you have two files called main.cpp.

If you publish the program in question we can investigate it further.

Thanks,

Dan

26 Jun 2012

Hi Dan,

I was already running the beta compiler on Friday when it was working. There's only the one mbed library and main.cpp, well as far as I can see anyway :-)

Published at:

http://mbed.org/users/Stavlin/code/DataLogger/

Joe

26 Jun 2012

Hi Joe,

This should now be fixed - if you click on the 'FatFileSystem' library in your program and click 'update' - it will remove the duplicate copy of the mbed library which has been causing the problem.

Thanks,

Dan

26 Jun 2012

Hi Dan,

Thanks for that, all working great now.

Joe

18 Aug 2012

Hi All I Thought had a similar error: When I compiled I got "More than one section matches selector - cannot all be FIRST/LAST".

My problem was, I had put in the mbed-export library in my project, but I didn't need it. I removed mbed-export, and it compiles fine.

Cheers, thanks for the great community, neat tools. W

You need to log in to post a reply