Online compiler is deleting my files?

29 Nov 2018

Hi, Im experiencing souch a weird big problem, when I try to compile my program (i have been programming using the online mbed IDE since 2 years) some of my .cpp files get deleted by the compiler (not the file itself but the content of some cpp and .h files)

Sometimes in the "Revision" tab I can see that my files have been deleted, but in the editor i keep seeing it fine.

For exame, in the following screenshot the content of board.cpp file seems to be deleted, but the file did not suffer any change:

/media/uploads/icarballeda/screenshot_from_2018-11-29_17-36-47.png

But, when i try to build my program, the compiler fails and says that for example some .o cant be generated, like if board.cpp was really empy.

Also, I can not CLONE my own programs (i try all kind of names for the new clone), maybe these are related problems:

/media/uploads/icarballeda/screenshot_from_2018-11-29_17-49-06.png

Also, im getting this error, and other files replace their content by this message:

alert('ERROR: There has been an error opening your workspace. Please try again later or contact support@mbed.com.');

And im getting this Error...

/media/uploads/icarballeda/screenshot_from_2018-11-29_17-59-37.png

My target device is an xDot, Online IDE compiler 1.10.24 libXdot 3.0.0 mbed Os 5.4.7

Please try to reply as soon as possible, thanks in advanced, Ignacio

30 Nov 2018

Hello, I have the same problem. When I try to compile any project, even a working project, if I make a simple change like adding a comment I get this message "Undefined symbol $Super$$main (referred from /extras/mbed/TARGET_KL25Z/TOOLCHAIN_ARM_STD/retarget.o).".

The problem is that all my main files are now empty and I don't have backups...

/media/uploads/sgtpepper335/empty.png

30 Nov 2018

I am experiencing both the copy/clone error and the random clearing of all contents of .cpp files.

30 Nov 2018

The problem seems to be solved, is there anyway to recover the deleted files ?

30 Nov 2018

I got exactely the same concern, file are empty and so I get .o missing function when linking.

30 Nov 2018

The same problem happened to me, the files that I was altering around 4:20 pm - Brazil time was left empty. I found it strange because when compiling the project it presented an error L6218E and when consulting the documentation, I did not find anything that I had altered that could justify the failure./media/uploads/marcusncunha/error_mbed.png

30 Nov 2018

It seems that it have been solved. It is working now. I guess someone has re-booted the compiler for us. try again.

30 Nov 2018

For my account, it still has the same problem ... I still have the files deleted

30 Nov 2018

Its working right now...

MARCUS NEVES CUNHA wrote:

For my account, it still has the same problem ... I still have the files deleted

The files will not appear by themselves, you have to recover it by hand file by file copy pasting from the change logs. Awful but it works... Admis, where are you guys?

01 Dec 2018

You can read about the cause of the file blanking issue and how to request access to the most recent backup of your program here http://mbed.status.io/pages/incident/54469719c3190ae461000071/5c01453e9ed95204b4ab79a7

09 Dec 2018

My file was blanked today. So this is still an issue?

09 Dec 2018

Indeed. A main.cpp file into my project set to empty. Back with a backup but erratic linker errors (Undefined symbol).

21 Dec 2018

The same error occurred again yesterday and today. Means II am stopped working on my projects. A global search will still show hits into files which show empty when trying to read them. Compiles fails though.... Admin, any ideas what is causing this and when this may be fixed for good? Thanks! Johannes

21 Dec 2018

If your file gets wiped upon being saved in the Online Compiler, please email support@mbed.com including your username and the name of the project affected.

Johannes Heupel wrote:

The same error occurred again yesterday and today. Means II am stopped working on my projects. A global search will still show hits into files which show empty when trying to read them. Compiles fails though.... Admin, any ideas what is causing this and when this may be fixed for good? Thanks! Johannes

The most recent backup of your lost project has been added to your Online Compiler workspace. It has _restore appended to the end of the project name. From this you can restore any wiped files.

Please log in to post a reply.