Serial communication MBED - PC issue, normal steps don't help.

18 Jan 2012

Dear all,

On the forum I found many posts about problems with the serial communication between MBED and the pc. I agree that these contain solutions that are helpful in most cases (I know because I have used them before). However, despite everything I read about trying to get a serial communication up-and-running again, I do not have found a solution for my issue.

let me post the issue and the steps I have taken (also based on information of many other forum postings):

System: Windows 7 (32bits), MBED LPC1768

Problem: no serial communication possible


Status device manager:

Ports (COM & LPT)

> mbed Serial Port (COM3) with exclamation mark (This device cannot start (code 10) )

Universal Serial Bus Controllers > mbed Composite Device

> USB Composite Device

> USB Mass Storage Device

> USB Root Hub (#x)

Steps taken:

- Remove drivers from ‘Ports’ and ‘Universal Serial Bus Controller’ by using uninstall in Device Manager

- Also removed drivers manually from c:Windows/System32/Drivers/ mbed_Composite_x64.sys, mbedSerial_x64.sys They appeared to still exist after the previous step.

- Reboot of system

- Plug in the MBED device > Windows starts automatically installing a driver

Status device manager:

Ports (COM & LPT)

no mbed yet (which is ok as I haven’t installed the mbed driver yet)

Universal Serial Bus Controllers

USB Composite Device

USB Mass Storage Device

- Install official mbed driver mbedWinSerial_16466 (which I obtained by using the Chrome browser, so not IE) > I end up with the same status of my device manager as the initial START one. So now I do have:

Ports (COM & LPT)

mbed Serial Port (COM3) with exclamation mark (This device cannot start (code 10) )

- I tried rebooting on this step as well as without rebooting on this step. No difference.

- Changing the port number to another free port does not resolve this issue.

- If I disable and then enable the mbed Serial Port then the exclamation mark and error ‘(This device cannot start (code 10) )’ has disappeared and I end up with the status that the device should be working properly. However, I still get no ‘hello world’ message on my machine so the problem isn’t resolved at all.

- Using other USB ports to plug in my mbed device isn’t a solution either.


- I have used mbed devices many times before on the same PC system, so it should work.

- This specific mbed device works fine on another PC, I do get a ‘hello world’ here, so it’s not broke.

- Besides this, I am sure that my code is running properly as I have used the LEDs to verify by letting them flash in a certain identifiable pattern.

- I obviously tried variations on the above scheme but this didn't help.

- In one variation I used mbed search in regedit and removed one file with MBED in the name (can't recall). No solution either.

What can I do or try to get the serial communication up and running again? I hope somebody has a clue what to do because I am lost here.

Thank you.

20 Jan 2012

Additional note:

I said that the MBED worked properly on another PC. However, when I tried more difficult code and a senor on that same computer, it didn't work. I assumed it just was the more complicated code.

However, now I have switched the MBED with somebody elses. Now everything works fine at my PC, including the complicated code. But my original MBED also doesn't work at all (same problem) at the PC of the guy I exchanged MBEDs with.

So the most logic conclusion seems to be: this MBED is broke after all as it doesn't work properly at my computer or from a colleague. And one collegue did have some output but when the MBED had to give some other output (complicated code) than is also didn't function properly.

My MBED is like almost brand new in use. Is there a test protocol before I can finally conclude that the MBED is broke indeed and I send it back to MBED to get a new one?

20 Jan 2012

Maybe a bad USB cable or connector, have you switched that too when testing other mbeds on your PC

27 Feb 2012

Hello, I had the same exclamation mark problem in the device manager when i connected the mbed. I found the solution on another forum: uninstall the current drivers of then install the prolific usb to serial adapter driver, available here: No reboot was necessary, and worked just fine for me. Hope it will solve your problem.

28 Aug 2013

Hello,I had the same problem,but I solved.The first ,I delete mbed composite device in the universal serial bus controller.The second ,re-install mbedWinSerial_16466.