USB filesystem freezing up

03 May 2011

Hi Guys,

I seem to have an annoying problem working with my Mbed.

It seems that the mbed drive on my Windows7 machine is freezing when I try to upload a new program. The way I usually resolve this is disconnecting the Mbed and reconnecting it while holding down the reset button. When I try that a couple of times I can format the drive and upload my new program.

This is very annoying, as I loose my serial line when disconnecting the mbed.

I have tried another Mbed, but with same results.

What am I doing wrong?

Kind regards


03 May 2011
03 May 2011

"The way I usually resolve this is disconnecting the Mbed and reconnecting it while holding down the reset button."

your not leaving a file open in your running program are you? The only way to get back in when you do is to hold down the reset button, which gives the drive back to the PC.

03 May 2011

Hi Jesper, Serge,

We're going to do some soak testing on Windows 7 to see if we can reproduce this problem. I've seen a couple of reports like this, and they always specific to Windows 7, so I'm wondering if there is something changed with the USB drivers provided by Windows 7 that is causing it not to behave properly.

If you have anything that reproduces the problem in a non-intermittent way, i'd be very interested. Also, what USB hardware you are using (i.e. make/model of your PC) incase it is specific to certain driver loaded by windows.



03 May 2011

Hello Simon,

Thanks for getting back regarding this issue.

I am able to re-produce 100% within a 12 hour time span sending packets like this at a rate of once per 5 seconds. Also at least 15-20 30-40Kb writes to the USB "share" of the embed when uploading a new .bin

Tue May  3 14:08:18 2011

p:953.69 hPa / t: 26.50 C
rh: 42.37 / t: 24.62 / dew: 10.99
heading 163.10
GPS Course -> 37.8, GPS Speed -> 0.0
lat 36.218870 <-> lon 12.197990   [fix age 0] [hdop -> 2280]

Hardware is a Lenovo W510 laptop with an Intel 5 Series/3400 Chipset Family USB Enhanced Host Controller. OS is Windows 7 Pro


03 May 2011

Perfect, thanks serge. We'll rig this up and see what we can find.

Thanks again, Simon

06 May 2011


I have been testing with a new USB cable for two days now and have yet to have an issue, so as David pointed out in the other thread I started about this issue, it could simply be a bad cable.

Jesper, can you swap out the cable and try another?

Thanks, Serge

10 Feb 2012

Hello, I am having a similar problem to the one mentioned originally (USB disk recognized initially, but freezes up when downloading new program). Was the problem ever resolved?

Like Serge, the machine in question is also a Lenovo laptop, but an E520 model - has Intel 6 Series/C200 Chipset Family USB Enhanced Host Controller. OS is Windows 7 Home Premium.

I have not tried any of the various "tricks" to get it working on my Lenovo, because I also have a desktop PC that works fine, so I can recover the filesystem by connecting to that machine. I have recently upgraded the desktop PC to Windows 7 Home Premium (previously running Vista), but interestingly it doesn't seem to have a problem with the mbed filesystem like the Lenovo does. For reference, the desktop PC has an Intel ICH8 Family USB Universal Host Controller.

Another clue (but perhaps not very helpful) is that if I wait long enough for the file copy operation it will eventually time out and pop up a message box with I/O device error 0x8007045D.

I see another forum topic that looks similar here including once comment about another user with a Lenovo, so perhaps this is a clue? In my case however it doesn't seem to have anything to do with the choice of browser, because I'm just copying a .bin file from my hard drive to the mbed using explorer, and it still freezes up.

Would be keen to hear if a fix was ever identified for this issue - would be nice to be able to use my mbed with the Laptop rather than being tethered to a desktop PC...

Cheers Andrew

09 Apr 2012

Hi Andrew, have you gotten your mbed to work with your Lenovo notebook? I'm having trouble and I only have Thinkpads. I've tested my mbed on three Thinkpads so far and none work, but it could be due to software conflicts as the Thinkpads I tested are all from my department and all have similar programs installed.

Later this week I'll test on other Thinkpads from work...

12 Apr 2012

Hi FRiC,

No, I never did get the mbed working with my Lenovo notebook. I see on your other postings you've had some success by adding a USB hub. I'll try that sometime to see if it helps.

12 Apr 2012

Hi Andrew, thanks for replying.

I find it hard to believe that it could be a compatiblity problem with Intel's mobile ICH/USB chipset, but I can't seem use my mbed on any notebook with an Intel chipset, without using the usb hub trick.

I'm thinking maybe my mbed is bad, but I'm going to email support and see what they say.

08 Jul 2013

I'm running the latest firmware as of last week, and my LPC1768 still freezes quite often when copying my binary over. The only way to recover is to unplug and try again. Has this issue been resolved? I assume not because I'm experiencing this with the latest firmware, but maybe there's something I missed.