Important changes to forums

We’re making some changes to the Mbed forums. From 10th December 2019 all new discussions will take place on our new forum site. You can continue to reply to existing threads for the next two weeks. After that we will archive this forum so you can return to useful posts in the future.

Windows 7 multiple mbeds BSOD

05 Oct 2010

Hey guys,

I have Windows 7 and 2 mbeds. When I try to connect multiple mbeds (in my case 2 mbeds) to my PC at the same time, I get a BSOD! It halts halfway down nusb3xhc.sys or something, so it ain't pretty. When individually connected, both mbeds work perfectly on my PC. But when I wanted them to interact when prototyping with some nRF24L01+'s, I could only get the mbeds to talk to one another when they are both connected to different PC's. This is really annoying, because I want to be able to work from one development system (shortage of space).

Has anybody else had this problem and if so, how did you solve it / work around it?

Let me know!

Cheers,

BigDaddy

05 Oct 2010

Hi Sander,

Thanks for reporting this - sorry to hear you are having problems.

Each mbed Microcontroller has its own unique ID that it presents to the USB Host controller, which means the OS should be able to tell them apart. This is also the reason that you have to run the serial installer for each individual mbed and was done so that you could have multiple mbeds attached to a PC without getting BSOD.. hmmm.

On Windows XP, I have personally had 6 connected at once without trouble, so I think the system works generally, but thats not much help to you.

The first thing I'd ask everybody is for thier comments on multiple mbeds plugged into Windows 7 - to get a feel whether this is a common experience, or if you have been unlucky.

Secondly, could you plug in your mbeds one at a time, and have a look in the device manager, at the ID of each mbed? It would be good to establish they they are enumerating as unique devices.

Let us know how you get on...

Thanks,

Chris

 

 

05 Oct 2010

Hello There

Ive had 2 no problem - Windows 7 , 64bit , Ultimate

Cheers

Dave

 

06 Oct 2010

Chris, Dave,

Thanks for responding. I also got the feeling that this behavior was not exactly 'as expected' and I have indeed heard of people connecting multiple mbeds at the same time no problems. I guess I am unlucky. So venturing a little deeper into my problem space, I noticed that my development PC has a USB 3.0 hub. Maybe to Windows 7, this kind of hardware is still a little too experimental, so the driver crashes when it can't tell two devices apart (although of course this should never happen). After all, my BSOD said it halted during execution of 'nusb3xhc.sys', which might be a clue.

Then again, when I tried other USB ports on the same PC, the problem keeps occurring. Anyway, I tried to retrieve the IDs of both mbeds in the device manager, and only on some obscure details page could I tell them apart. Under 'Schijfstations' ('disk stations' in international / english versions I presume), both times an 'mbed Microcontroller USB Device' is listed. The properties of both devices look all the same to me, except for the 'details' tab. There I found a property which in my Windows version is called 'Naam van fysiek apparaatobject'. I guess it loosely translates to 'Name of Physical Device object' or something. For this particular property, the values differ: \Device\00000108 for the one and \Device\0000010b for the other.

So I guess my OS can tell them apart, but I'm not sure my USB drivers have the same indispensable discerning capabilities.

If anybody has any ideas, drop a line...

Thanks,

Sander

06 Oct 2010

Hi Sander,

Are you using 32 or 64, and is it theHome or Professional version.

You are right that it does sound like the USB 3.0 is where it is breaking things. Can you confirm if the onboard USB (presumably on the PCs motherboard) is USB 3.0 as well? From what you said it sounds like you get BSOD even plugging them in directly, i.e. without the hub. When you plug them in directly, is the USB 3.0 hub also connected? Does it make any difference if youplug them in directly *without* the hub attached.

Finally, can you tell us the make/model of the hub. We should be able to get one of these in and do some testing.

Many thanks

Chris

06 Oct 2010

Hey Chris,

I can indeed confirm that the on-board USB is USB 3.0. My development PC is a  HP Elitebook 8540w, Core i5 M520 @ 2.4 GHz with 4.0 Gb RAM. On it I run Windows 7 64 bit Professional version.

When I mentioned 'USB hub' I should have clarified. By experience I have learned to never connect any hardware that runs on USB power to my PC via an external USB hub, so I'm not using an external device. With 'USB Hub' I meant the 'NEC Electronics USB 3.0 Root Hub' (as it is called in the device manager) that drives some of the USB ports that come out of the side of my Elitebook. There is also another USB controller present on the system (a root hub), which drives other USB 2.0 ports. Not any combination of connections with both mbeds yields any other thing than a solid BSOD. So you're right: I do get a BSOD even when plugging them in directly, even when using the USB 2.0 ports. The weird thing is, the system always halts during execution of 'nusb3xhc.sys', which indicates a USB 3.0 problem even when using all USB 2.0 ports. I can't get my head around it.

Thanks for your time dude.

Greets,

Sander

06 Oct 2010

Hi Sander,

Thanks for the update, and the detailed scenario.

It seems that reglardless of how you hook them up, the two mbeds confuse the USB 3.0 driver. I dont know enough about the enumeration process to comment, especially with USB 2.0 and 3.0 co-existing. I'll get hold of a USB 3.0 hub here, and see if I can make my natively USB 2.0 machine also keel over when USB 3.0 is present.

Watch this space!


Thanks,

Chris

08 Oct 2010

I have been expierencing simliar problems on a Lenovo W510, 64-bit Windows 7 laptop.  My problem has to do when I plug in an MBED unit and then another unrelated USB device, which in my case is a Cables Unlmited USB to Parallel Port adapter.  The Cables Unlmited device is a USB 1.1 device, so I'm not sure if the issue has to do with duplicate USB IDs.  The Lenovo W510 is also a USB 3.0 product and the error I receive has to do with nusb3xhc.sys as well.

I have not expereinced any BSOD on this laptop until I started usind the MBED, now it happens on demand, so there is a definite link.

If there is any othe information I can provide, please let me know.

Thanks,

Steven

11 Jan 2011

I get BSOD with a single mbed on a Dell XPS L501X.  All are USB 3.0 ports. It's a Renesas controller.

07 Sep 2012

One of our students has a 1 yr old MSI laptop with both USB 2.0 and USB 3.0 connectors. Any single mbed in a USB 3.0 port gives an instant BSOD. It works fine in one of the USB 2.0 ports. On that PC, the 3.0 connectors are blue and 2.0 ones are black and on the other side.

You need to log in to post a reply