No output for printf statement on both TeraTerm and PuTTY.

08 May 2019

/media/uploads/gm600/6.png So I’m doing a little coding with an ST board, the Nucleo-F746ZG. /media/uploads/gm600/1.png

In my debugging statements, I was getting no output, so I made a test code to see what the issue was. It’s a very simple “hello world” followed by a LED blinking and a printf statement with each change of state of the LED. The LEDs on the board react as expected with all my codes so there is information being sent over to the board. However, none of my printf statements are returned. /media/uploads/gm600/2.png

The driver is working, with the device being recognised via an ST link.

These are my TeraTerm settings. I changed the new line receive to auto after no output was being shown from CR. As you can see the baud rate is the same. But still no output. /media/uploads/gm600/4.png /media/uploads/gm600/5.png /media/uploads/gm600/6.png

I then tried a different console PuTTY. With the same settings, still no output. /media/uploads/gm600/7.png /media/uploads/gm600/8.png

So I’ve tried different hardware, switching to a new USB cable. Still nothing. I’m lost here. IDK if it is a glaring code problem or something wrong with the board, which I doubt as it had been used before me with no issues.

Please log in to post a reply.