USB Serial port issue on Windows 10 with u-blox C027 board

25 Feb 2019

I am trying to connect and program a u-blox C027 board over USB to my laptop which is running windows 10 home 64 bit.

I am using the standard Microsoft usb serial port drivers (10.0.17134.1) and have also tried the MBED serial driver at the latest version on the website.

In both cases the CMSIS-DAP flash drive is successfully created - as is a USB serial port (Either com6 or com7) - after about 30 secs a secondary file is created the CMSIS-DAP area. The filename is "fail" and the content is the text "TIMEOUT"

The serial port can be opened and closed via i.e. PuTTY - LEDs on the C027 board indicate that data is being passed to the port, but no response is received.

The same boards (And USB cable) work successfully with no changes on my colleagues laptop which is Windows 7

01 Apr 2019

Just saw you post today, it would have been better if you would have contacted on C027 or u-blox page.

Have you tried https://os.mbed.com/users/ublox/notebook/ublox-C027-Update-CMSIS-DAP-Interface-Firmware/ ?

(Better to use latest FW from https://github.com/ARMmbed/DAPLink/releases)

13 Apr 2019

Many thanks for your response - this is what fixed the issue Kr Andy

You need to log in to post a reply